0

I'm trying to create some accessibility Skip links to be used with screen readers. I added the links at the top of the body tag and I added a corresponding anchor tag to both the main navigation and the main tag. The links work as expected on the homepage but no matter what page I'm in it will always take me back to the home page anchor links. I inspect the code and it shows href="#main" and href="#main" so I don't know why they keep sending me to the anchor links on the home page.

This is fresh install of 3.7; I don't have any 3rd party extensions or plugins installed. I tried with SEF On and Off and I still get the same results. I'm new to Joomla so I don't know if there's a setting I have to turn on.

Any help would be appreciated.

Thanx

0

If you want Joomla to be compatible with a small screen such as smartphones that will have little effect. This is how the templates show your actual content you can either look for a template that is built in such a way.

I did manage to quick google this if getting the right template will not be of any help: http://webaim.org/techniques/skipnav/

0

This sounds more of the menu configuration that is acting in place. Create a new menu item and set it to some internal page or article and see what happens.

Question for you: Did you install any one-pager templates on your site?

0

In respond to @Paul Raver, this technique is used more for desktop as I doubt there are any mobile screen readers. What it does is it adds links only visible to screen readers. Users are then able to tab to specific areas of your website without needing to go through other content that might not be important to them.

It's really a simple thing. It just a tags pointing to anchors on different sections of the page. The a tags are visually hidden using CSS styling. I've used this simple technique numerous times without any problems. However, this is the first time I'm developing a Joomla site and this is where my dilemma is as in no matter what page I'm at the links always take me to the anchors on the home page.

After doing research of the Joomla system and looking through the system I finally got it to work although I'm not sure why so I'm still a little confused. I disabled all SEO Settings in Global configuration and then I also disabled all System plugins. I then enabled all the settings again. All of a sudden the links work correctly. I don't know if it just needed a reset or what, but it's working now.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.