1

My website do not open administrator login instead it redirect me to the home page I have to repair error by using cpanel any body have suggestions

  • Just to confirm - are you going to /administrator rather than using a login form on the front of the site? – Richard B Apr 16 '17 at 10:29
  • Could you access it in the past? What changed? – jamesgarrett Apr 16 '17 at 23:09
  • suddenly I could not open login to administrator page! but the cpanel still access and working! – Eng Roza Apr 19 '17 at 6:47
  • Have you solved this problem? – TheNextStage Jun 26 '17 at 22:39
1

For Akeeba Admin Tools, the responsible file is:

root joomla install/plugins/system/admintools/admintools/main.php

Rename that file, access the site as normal, and use the Admin Tools to unblock yourself. Rename the file back to main.php.

0

Check if you had JSecure plugin, or if you have correct permissions for folder and index.php in admin folder.

644 are the correct one.

Some servers are not allowing to use and hide files and folders with incorrect permissions from the web

  • I did not get it and the prob continue to exist. – Eng Roza Apr 19 '17 at 6:53
  • Clear your browser cache and temp files – Terry Carter Apr 20 '17 at 3:13
0

This problem is likely caused by a security plugin that was installed on your Joomla website - in most cases it is Admin Tools, in some cases, it is a different plugin such as JSecure. We have explained how to fix the problem in the case of JSecure here.

Since you already stated that you don't have JSecure installed, then I would say this is caused by Admin Tools - either disable the Admin Tools plugins from phpMyAdmin, or rename all the Admin Tools folders in your filesystem to _old (just append _old to the folder name).

0

To add to what @itoctopus said, if you're running Akeeba Admin Tools, go to Admin Tools then go to Web Application Firewall. Then click on Configure WAF and under Basic Protection Features tab check to see if Allow administrator access only to IPs in Whitelist is set to Yes. If it is, you can set it to No or add your IP to the white list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.