0

I developed a Joomla 3.6 site deployed on local host. It was working absolutely fine. However, the site is completely broken after uploading to the remote host(http://polluscope.uvsq.fr/Polluscope/). I am guessing some extensions are missing. But any suggestions would be highly appreciated.

1

Is the link (path to your site) correct? You have a folder under a subdomain, i thought that was strange so i checked just the subdomain http://polluscope.uvsq.fr there was the restore steps from Akeba and after clicking start over the site worked (the site that you can see now in my link appeared) is that your site?

  • Hello John, yes. I solved the problem. This is why it is working fine now :) – user2711722 Apr 2 '17 at 21:41
0

The errors are almost all 403 Forbidden which is probably caused by your .htaccess file. To verify, you can temporarily remove the .htaccess from the root of your site via FTP and see if those resources load without it.

You can either revert to the default Joomla htaccess (rename htaccess.txt) or if you are using the master htaccess by Nicholas K. Dionysopoulos, make sure you go through and do a find/replace for all instances of example.com and example/.com as that is what allows exceptions for your domain name. https://github.com/nikosdion/master-htaccess/blob/master/htaccess.txt

  • Hi @YelloWebMonkey. Thanks a lot for the reply impromptu. I tried both options you mentioned. The site has been changed a bit but the problem persists :( I think its not loading some modules such as slider.. – user2711722 Mar 31 '17 at 13:01
  • Do you have a Rewrite Base / value set in htaccess? What about the $live_site variable in configuration.php? – YellowWebMonkey Mar 31 '17 at 20:37
  • Here is my htaccess.txt file: github.com/demohaq/Polluscope/blob/master/httpaccess.txt – user2711722 Apr 1 '17 at 13:18
0

How did you upload your website? Did you copy all files via ftp and import a database dump or did you use a backup extension?

Did you realy use Joomal! Version 2.5? This version is not supported any more: https://downloads.joomla.org/de/cms/joomla25/2-5-28

  • I zipped the files and uploaded via ftp. No it was mistake, I used 3.6.4. – user2711722 Apr 1 '17 at 12:43
  • And how did you upload the database data? Did you adjust the file configuration.php – astridx Apr 1 '17 at 17:42
  • I used PhpMyadmin. Yes, I made changes in configuration.php. I think the modules are not loading. For instance, I have K2 for slider. Do I have to do changes in apache server configuration file such as .htaccess file? – user2711722 Apr 1 '17 at 18:33
  • I would first update to 3.6.5, because it is a security release joomla.org/announcements/release-news/… As you use the same .htaccess on the local and on the remote server I do not think, that this file is the issue. Are the PHP Version different on remote and local? – astridx Apr 1 '17 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.