2

I have added following code to my Joomla template index.php:

<noscript>
    <div></div>
    <link rel=stylesheet href="/media/style.css"/>
</noscript>

But Joomla changed it into:

<noscript>&lt;div&gt;&lt;/div&gt;&lt;link rel=stylesheet href="/media/style.css"/&gt;</noscript>

Which won't work because of missing angel brackets.

Code is inside , but putting it into body didn't help. Also creating a module returned same result. I know that div tag doesn't make any sense. It is only for testing and removing it doesn't help.

Does anyone know, how to prevent Joomla from messing my noscript tags? Thanks in advance for any advices!

6
  • 1
    By default, Joomla does not convert any HTML to it's respected entity in the template's index.php file. If this is happening, it's most likely a template helper file or a plugin doing so.
    – Lodder
    Commented Mar 23, 2017 at 13:53
  • I have disabled all modules and all plugins with ID greater than 10000, then reduced my index.php (inside template) to: <!DOCTYPE html> <html> <head> <noscript> <link rel=stylesheet href="/media/style.css"/> </noscript> </head> <body> </body> </html> But it returned same result. Are you sure, that it isn't basic Joomla action? I am using Joomla 3.6.5.
    – Patryk
    Commented Mar 23, 2017 at 15:52
  • Have just tried to disable also plugins with ID below 10000 (so all modules and plugins disabled), but still no luck.
    – Patryk
    Commented Mar 23, 2017 at 16:06
  • 1
    Where are you seeing &lt;div&gt;&lt;/div&gt;&lt;? On the actual page or when you open your browser inspector? Also, which template are you using?
    – Lodder
    Commented Mar 23, 2017 at 16:10
  • It's Chrome bug. I have posted an answer. Thank you for help!
    – Patryk
    Commented Mar 23, 2017 at 16:20

1 Answer 1

1

Turns out it's bug in Chrome (link). Haven't encountered it before and that's why my first thought was that it's connected with Joomla. Sorry for my mistake!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.