3

I have been asked to help maintain a custom component that has already been installed on a server, but had no ACL.

I followed the sample tutorial in adding both XML files (Access.xml and config.xml) into the component directory show it shows up in the ACL Manager.

However, if you enable it for a group, it doesn't appear in the menu for them to select.

I would appreciate any suggestions on where to focus my attention. I do know how to use ACL, but where there was no install done for this component, i think something is missing.

TIA

1

It seems you mispelled the filename the correct name is access.xml without the capital A. Another thing you might want to look at is if you added the rules field in config.xml file. Lastly, if you have declared both of these files in your component's manifest in the administrator files part. Like so: Note: I just put the revelant part of what your component manifest should look like in order to work properly as you expect it to be. I also assume that you have the latest stable installed version of Joomla! at time of writing this answer it's Joomla! 3.9.28

<!-- more before -->

<administration>
        <!-- Administration Main File Copy Section -->
        <!-- Note the folder attribute: This attribute describes the folder
            to copy FROM in the package to install therefore files copied
            in this section are copied from /admin/ in the package -->
        <files folder="admin">
            <!-- Admin Main File Copy Section -->
            <filename>config.xml</filename>
            <filename>access.xml</filename>
            <!-- more after -->
        </files>
<!-- more after -->
</administration>

Just to be complete, I give you the link to the official documentation related to this point:

Click here to learn more

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.