2

I'm having some trouble with a couple of sites with mixed content and ssl from Cloudflare. Normally all I need to do is install the plugin from SimBunch and then setup all of my redirects from http to https, but for some reason a few of my sites are having major difficulty with this process.

Website in Question: https://www.ashleyrowlett.com

I have tried absolutely everything I can think of and every suggestion I've found in forums. livesite is set to https version in the configuration file, but there are TONS of files still loading the http version causing the mixed content. Caches are all turned off and cleared - I've searched my template for any http references and found nothing. I've tried switching templates to the default Joomla templates to test, same results.

Hosting company can't help me. Cloudflare can't help me. Simbunch can't help me. Not sure where else to go or to try.

Does ANYONE have any ideas? Thanks in advance!

Referenced things I've tried:

2
  • 1
    In the linked website - your base href is http://www.ashleyrowlett.com - and all assets files (css/js etc) seem to be loaded from http - so it looks like Joomla is still under http. Are you sure you have forced the site to load under https?
    – FFrewin
    Commented Mar 18, 2017 at 8:08
  • Yes - I have live site set as public $live_site = 'ashleyrowlett.com'; but it has no effect on the base url.
    – Brandon
    Commented Mar 20, 2017 at 15:41

1 Answer 1

2

Your baseUrl points to the insecure version, so your sites base href does too.

You can set the correct secure version in your configuration.php file:

public $live_site = 'https://www.ashleyrowlett.com'; 
4
  • That's what I currently have set at the moment for the site, but it has no effect at all on the urls and I can't understand why.
    – Brandon
    Commented Mar 20, 2017 at 15:40
  • You're looking at cached pages? Commented Mar 20, 2017 at 16:12
  • That's possible, but they seem to be cached everywhere and I've cleared browser caches, CloudFlare caches, Joomla caches and disabled any caching that I can find anywhere as mentioned in my original posting. Not sure where else it could be cached.
    – Brandon
    Commented Mar 20, 2017 at 16:17
  • If my answer helped then perhaps you can mark it as correct? Commented Aug 7, 2017 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.