I'm new to Joomla, my site was working almost fine for many weeks but suddenly i'm getting this error "Your host needs to use PHP 5.3.10 or higher to run this version of Joomla!" so i asked my provider to upgrade the php, they ignored as they normally do. I want to know why suddenly this error pops up? i didn't upgrade Joomla version (Current Joomla version 3.3.6, PHP version 5.3.3) Does anyone know how to resolve this issue.
If you used the hosting built-in 1-click-installer for Joomla, then you probably managed to bypass the minimum PHP version requirements.
However you wont be able to use Joomla until you upgrade to atleast 5.3.10, as stated in the requirements:
If you're hosting provider is ignoring you, then perhaps you need to consider someone better.