2

I'm new to Joomla, my site was working almost fine for many weeks but suddenly i'm getting this error "Your host needs to use PHP 5.3.10 or higher to run this version of Joomla!" so i asked my provider to upgrade the php, they ignored as they normally do. I want to know why suddenly this error pops up? i didn't upgrade Joomla version (Current Joomla version 3.3.6, PHP version 5.3.3) Does anyone know how to resolve this issue.

  • Ideally you should set the PHP to a supported version as per php.net/supported-versions.php. You may be able to do this yourself via the PHP selector in cPanel or similar. Right now, PHP 7.0 is probably the best version for the latest version of Joomla (currently v3.6.5). – Neil Robertson Mar 16 '17 at 10:33
3

If you used the hosting built-in 1-click-installer for Joomla, then you probably managed to bypass the minimum PHP version requirements.

However you wont be able to use Joomla until you upgrade to atleast 5.3.10, as stated in the requirements:

https://downloads.joomla.org/technical-requirements

If you're hosting provider is ignoring you, then perhaps you need to consider someone better.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.