1

My provider recently removed an older PHP version and I forgot to update one of the Joomla installations. Now I'm left with a broken front- and backend that only shows me

enter image description here

What now? Is there any way I can fix this. I have of course ftp access to the site. Is there any good description of how to proceed?

  • What version of Joomla are you using? You'd be best off contacting your hosting provider as this message is not displayed by the Joomla CMS – Lodder Feb 20 '17 at 14:20
  • @Lodder What I see from the Readme in the installation it's 3.4, but I'm not sure how many updates I have installed after the initial installation. Or is the Readme updated as well? – halirutan Feb 20 '17 at 14:25
  • Maybe it is possible to extract and copy a new installation to the server without altering with the config, templates, etc? – halirutan Feb 20 '17 at 14:32
  • What version of PHP are you running? – Lodder Feb 20 '17 at 14:33
  • 1
    @Lodder Ok, thanks for holding my hand :) It turns out, I could edit .htaccess and increase the ancient version that is referenced there. It is working again. – halirutan Feb 20 '17 at 14:42
3

The fix was easy. The problem was the .htaccess file in the root directory of the installation. There, you find at the very beginning something like this

AddHandler php55-cgi .php

In my case, this pointed to php53-cgi which my provider did not support any longer. I looked up, what versions are available now and found a listing:

enter image description here

After editing the .htaccess file and manually setting it to php5-cgi I could access my site again and update the Joomla installation. After the update, .htaccess now points to php55.

  • 1
    Just FYI, be sure to use PHP 7 as this will boost your performance by 200% – Lodder Feb 20 '17 at 15:04
  • Handling the server's php handler on the htaccess is not a standard in what Joomla provides as a sample htaccess file and is not related with Joomla in any level. – FFrewin Jul 27 '17 at 9:57
  • @FFewin What is your point? If I knew that it was not Joomla related (although it was my Joomla page that stopped working), I wouldn't have asked on a Joomla site in the first place. After finding out that the problem was how my web-provider handles php I figured that someone might run into a similar problem and I better post my findings. Why are you so narrow-minded here? Obviously at least 4 people ran into similar problems. – halirutan Jul 27 '17 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.