1

I am trying to copy a Linux-hosted Joomla! site onto my local IIS 7.5 server. The local site home page is OK but when I click on a menu item (e.g. "set-up") I get an HTTP Error 404.0 - Not Found. Error Code is 0x80070002.

I tried many pages that are not the home page (http://localhost:41129) but failed. In other words, every page of the type http://localhost:41129/XXX causes an error.

I can see that the server simply tries to access a folder under the root (XXX) rather than extract a page from the data base.

I know that the local environment is fine because I managed to install a new Joomla! site from scratch and to add a working menu item.

The database is attached because I can see (from the backend) the list of users.

Exact error message:

HTTP Error 404.0 - Not Found The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

Most likely causes: The directory or file specified does not exist on the Web server. The URL contains a typographical error. A custom filter or module, such as URLScan, restricts access to the file.

Things you can try: Create the content on the Web server. Review the browser URL. Check the failed request tracing log and see which module is calling SetStatus. For more information, click here.

Detailed Error Information: Module IIS Web Core Notification
MapRequestHandler Handler StaticFile Error Code 0x80070002 Requested URL
httb://localhost:41129/component/search/?searchword=setup&searchphrase=all&Itemid=135 Physical Path C:\Users\Shaul\Documents\My Web Sites\LocalSpp1\component\search\ Logon Method Anonymous Logon User Anonymous Request Tracing Directory
C:\Users\Shaul\Documents\IISExpress\TraceLogFiles\LOCALSPP1

More Information: This error means that the file or directory does not exist on the server. Create the file or directory and try the request again. View more information »

1

The problem was in file web.config.

When Akeeba Kickstart script deploys a site on an IIS server, it does not move the contents of file web.config.txt to file web.config You need to do it manually.

0

This problem usually is caused when Joomla is configured to use SEF URLs with Rewrite Mode set to On, but the proper directive to enable Rewrites in the server's configuration is missing.

Apache
Rename the delivered with Joomla htaccess.txt file to .htaccess and make sure RewriteEngine On is uncommented.

RewriteEngine On

IIS 7
Rename the delivered web.config.txt file to web.config

In both cases make sure rewrite module is installed and enabled.

Nginx.config
Adjust your nginx.config

location / {
    try_files $uri $uri/ /index.php?$args;
}

Nginx setups may not give you access to the nginx.config or allow you to add custom nginx.config files in your site's root. Consult your hosting provider for additional help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.