3

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpNvO1BD' to '/home/kimberly/public_html/tmp/IMG_1934.JPG' in /home/kimberly/public_html/libraries/joomla/filesystem/file.php on line 351

This is the error message I get on my website whenever I try to upload any image file onto a blog or etc.

Kindly help me sort out this problem. Thanks.

  • 3
    Have you checked the directory permissions? – FFrewin Feb 2 '17 at 9:12
  • Yes, I went through all the system permissions via system info and saw all were writable. What I want to know though is, how to change folder permissions numbers like people write " Did you try changing folder permissions to 777 or 501 or something". I would be happy to know if you could let me know regarding the same. Thanks. – Uma Shankar Singh Feb 3 '17 at 2:52
  • The web server usually works as a user www-data or http, and not under your own user account. So the directory "/home/kimberly/public_html/tmp" has to get the right permissions for the server's access. – Tom Kuschel Feb 3 '17 at 20:27
  • Under directory permissions I see that directory permissions to the folder you mentioned has writable permission. In that case it shouldn't be a problem. It has something to do with libraries/joomla/filesystem/file.php line 351. Any idea whats that supposed to mean really? I have been trying my way around this, but just can't crack it. Is there somebody with whom I can get personally in touch with to deal with the issue? I am using Joomla version 1.5.22. – Uma Shankar Singh Feb 4 '17 at 3:46
  • Once you have fixed your permission, ownership or space problem, you should ideally upgrade to Joomla 1.5.26 and apply the Joomla 1.5 security hotfixes from: docs.joomla.org/Security_hotfixes_for_Joomla_EOL_versions to keep the website secure while you plan a migration to Joomla 3.x. – Neil Robertson Feb 5 '17 at 22:35
2

Make sure of the following:

  • The file/folder permissions are correct on the tmp folder. Typically, they should be 755.
  • The ownership is correct on the tmp folder. If you are running a cPanel/WHM environment, then the folder should be owned by the cPanel user. If you're running Plesk, then the folder should be owned by www-data.
| improve this answer | |
  • Thanks for the valuable information Mr. Neil. I found the place where we can adjust folder settings and stuff. All seems to be on 755 and images which are uploaded are on 644. And the user is same for all the folders and files. What now concerns me is that how do I find if I have any space left in my temporary folder or not. Because what happens is that when I upload an image, the image uploads and shows me as 0 bytes. When i click on the picture, its shown as a broken link. Kindly give me some idea as to how to find the space available on temp folder. Thanks. – Uma Shankar Singh Feb 6 '17 at 10:12
  • 1
    If you're running cPanel, then you should be able to know that information on the left pane in cPanel. – itoctopus Feb 6 '17 at 14:51
  • I used to be a content writer and don't have so much indepth knowledge about cpanel. I guess its not a usual .exe file which we can run and install the application. Any idea as to how to download cpanel on my system? – Uma Shankar Singh Feb 7 '17 at 7:14
2

Apart from file and folder permissions and ownership, you should also check you have sufficient free space to upload the file.

| improve this answer | |
  • I knew I was missing something! – itoctopus Feb 5 '17 at 16:50
  • Mr. Neil Robertson or Mr. Tom Kuschel or anybody who is an expert at this could you please share your personal email id's. I really am not able to figure out how to solve the issue. I will share the details to the website on email. Thanks. – Uma Shankar Singh Feb 7 '17 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.