0

I have been trying a lot lately to get this thing work.I'm using Joomla 3.6.5 and I am using JA University Template.I see when I log in through front end I am able to see the K2 edit icon for modules.but I don't see any edit icon for articles (K2 items).I have literally tried everything from user groups mapping to disabling Gzip compression.

please, let me know if I'm missing something.

  • I presume you have enabled frontend editing in the K2 Parameters. If you are logging into the frontend as a super admin then that should be all you need. The template shouldn't matter. – jamesgarrett Jan 30 '17 at 3:46
  • @jamesgarrett Thank you for your comment.yes i have enabled front end editing.but it isn't working. – Faheem Rasheed Feb 1 '17 at 5:38
  • are you using a k2 template override or have modified the default k2 template? The code that makes the edit button is in the k2 templates so if you are comfortable with editing the php you could modify either the category or item layouts to see what permissions are failing. – jamesgarrett Feb 1 '17 at 7:53
  • @jamesgarrett Could you please guide me on this.i'm basically from .NET background and yes i see no link for the Edit in HTML.There are list items for Print , Email and Font Resizer.had it been like a css issue it should atleast have been there. – Faheem Rasheed Feb 1 '17 at 13:19
1
  1. Go to Components -> K2 -> User Groups and check that the group Site Owner has the Front-end item editing as YES also there you can choose what categories can be edited or not.
  2. Go to Components -> K2 -> Users and search for super user, edit that account and select the K2 user group as Site Owner.

Save and now Super User should have frontpage edit privileges (if there are no template overrides).

1

First let's just confirm all the config steps.

  1. In the K2 parameters > frontend editing, 'Enable frontend editing'
    is set to yes.
  2. You have a K2 usergroup called editors (or something) and the permissions of the editors K2 usergroup includes at least 'Front-end item editing', 'Edit any item' & 'Allow editing of already published items' set to yes. Also the 'Assign group permissions to these categories' setting below is set to 'All' or something else appropriate.
  3. Your own K2 user matching your Joomla user is assigned to the editors group.
  4. You are logging in to the front end with the right user.
  5. You are using a K2 template that still includes the edit button. For example if you have a menu item pointed to a K2 category, the category_item.php file in the template that is active contains the following:
<?php if(isset($this->item->editLink)): ?>
<!-- Item edit link -->
<span class="catItemEditLink">
<a data-k2-modal="edit" href="<?php echo $this->item->editLink; ?>">
<?php echo JText::_('K2_EDIT_ITEM'); ?>
</a>
</span>
<?php endif; ?>
  • each of the point stands true. – Faheem Rasheed Feb 4 '17 at 16:42
  • I missed 1 step which I have added to item 2 in the list above. I notice by default the 'Assign group permissions to these categories' setting in the K2 usergroup is not set to anything. This should be set to 'All' or something suitable. – jamesgarrett Feb 4 '17 at 23:01
  • I have set it to all and also tried with other settings.didn't work out. – Faheem Rasheed Feb 5 '17 at 5:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.