2

Every time I got to the home page /index.php I run into a infinite loop. This happens only for the www.example.com/index.php, while www.example.com works fine.

Also this problem doesn't seem to exist when Search Engine Friendly URLs are tuned off. I have been fighting with it for over a week and tried reinstalling joomla multiple times but nothing seems to help.

Does anyone know what could be the problem?

  • This could be a server misconfiguration. If your web server is Apache, it could be a .htaccess issue. – Farahmand Jan 27 '17 at 9:42
  • Have you made any changes to your .htaccess file? – Lodder Jan 27 '17 at 11:08
  • Server is Apache. I used to have modified .htaccess but now i use only the one given with Joomla. This problem exists even if I did clean install of Joomla and didn't change anything. – bibixx Jan 27 '17 at 22:36
1

A few troubleshooting suggestions:

  1. Make sure you are using the exact htaccess.txt content that ships with Joomla in your .htaccess.

  2. Try this: Rename Joomla's index.php and create your own index.php file - then try to reach at it and see what happens. With this test you will know if it's something internal to Joomla or something from the server.

  3. Review the Joomla Core Redirect component for possible redirections enabled in there and disable them.

  4. Review your 3rd party extensions and disable plugins that might be involved - SEO/SEF or security plugins might have settings that create redirections.

  5. Review your home menu item - what component is being used there - try with different components/menu items.

  6. Check in your hosting control panel for any possible settings that may create redirections between site versions/protocols (https/www).

  7. Ask your hosting provider for support.

Remember to come back to this site, to post the cause of your issue when it's resolved - to help other users in the future.

  • Basically I have tried everything except #7 since #2 showed me that it must be a Joomla issue and that's why I have written this question. – bibixx Jan 28 '17 at 11:16
  • @bibixx :: So, when you reach at your own index.php you it doesn't redirect you? And are we talking about doing so on an existing website or a fresh Joomla install? #2 would mean that something is wrong with your J site if the site is an existing one and not a fresh Joomla install, as a totally fresh Joomla should work - if a fresh J install redirects you, then it still looks like it's a problem with the server. – FFrewin Jan 28 '17 at 11:22
  • And that's a really good question what could be the matter. I have been trying all the configurations I could possibly come up with and options in server's control panel for a week now and nothing seems to work. – bibixx Jan 28 '17 at 11:24
  • Uploading the latest J! version over your existing site should tell you if it is a configuration issue (database) or 3rd party extension as that will eliminate any possibility of corrupt core files. – Michael Yaeger Jan 28 '17 at 14:17
  • I have tried reinstalling completely (I have deleted all files from ftp and then uploaded them). It can't be matter of 3rd party extensions since even if i haven't enter backed the issues still exists. – bibixx Jan 28 '17 at 14:58
0
  1. In your Joomla! Administrator, navigate to System > Global Configuration.
  2. On the Site tab under "SEO Settings", make sure the following are set to "Yes":
    1. Search Engine Friendly URLs
    2. Use URL Rewriting
  3. If the web server uses Apache - Rename htaccess.txt to .htaccess and ensure mod_rewrite is enabled on your server. If you already have a .htaccess file at the web root, add the contents of htaccess.txt to the bottom of .htaccess and save.
  4. If the web server uses IIS - Rename web.config.txt to web.config and install IIS URL Rewrite Module. If you already have a web.config file at the web root, add the contents of web.config.txt to the bottom of web.config and save.

Recommended Reading:

  • Thanks for replay, but unfortunately it doesn't change anything. I have tried this multiple times. Also this time i have checked if mod_rewrite is enabled and it is. – bibixx Jan 27 '17 at 22:34
  • Have you checked the server's error logs for your site? If it is a PHP or Apache error, it could be there. – Michael Yaeger Jan 27 '17 at 23:40
  • No php errors whatsoever – bibixx Jan 28 '17 at 7:42
  • What about Apache errors? Try /var/log/apache/access.log. – Michael Yaeger Jan 28 '17 at 14:15
  • Unfortunately my hosting provider only gives me access to website folder and I don't know how to reach the logs. Is there any way I could change their location? – bibixx Jan 28 '17 at 14:20
0

So basically I have written to my hosting provider support. After small investigation they proposed to install Joomla in subfolder and then in control panel to point domain to that subfolder. I have done it and now it seems to work just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.