1

I changed both Search Engine Friendly URLs to Yes and Use URL Rewriting to Yes in Global Configuration and renamed the .htaccess.txt to .htaccess .

But, now none of my templates work anymore.

I have success in making the URLs cleaner (removing the index.php from them), but the templates break. The links work without any problem.

I tried to follow some tutorials without success:

  1. https://docs.joomla.org/Enabling_Search_Engine_Friendly_(SEF)_URLs_on_Apache
  2. http://www.viryatechnologies.com/Virya-Blogs/joomla-content-management-system/2012/11/29/removing-indexphp-from-existing-sef-urls.html

I believe the mod_rewrite module is not the problem because the "new" links work properly.

The site is hosted in a webserver using Apache. The Joomla version is 3.6.5 .

Does anyone have any idea about what can be happening?

  • can you be more specific when you say the templates break? Got a screen shot? Also have you checked the console for errors when you load a broken page? Sounds like there may be a permission issue keeping the template resources from loading. – Brian Peat Jan 25 '17 at 16:31
  • @BrianPeat, thank you for your answer. I already know what the problem was. I am using the JCH Optimize plugin. In the Basic Options tab, there is a Use url rewrite parameter. That was the problem. When I switched it to off, the conflict stopped. – Leonardo Pinheiro Jan 26 '17 at 14:34
1

I found the problem:

The templates were not at all responsible.

I am using the JCH Optimize plugin. In the Basic Options tab, there is a Use url rewrite parameter. That was the problem. When I switched it to off, the conflict stopped.

For some reason, it does not work well with the directives inside my .htaccess file.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.