0

On my XAMPP installation I install Joomla! 3.6.5 it gets to the database step, if I put in the wrong credentials it tells me so, if I put in the right credentials it does the loading screen. See this screenshot.

Joomla! Loading Screen

No database tables are ever created, no error message occurs, it just acts like it's loading for ages. It doesn't get to the next screen where it shows the steps for creating a database etc.

My XAMPP has been edited to use port 81, so I have used localhost:81 in my server settings.

I also moved my HTDOCS directory to another drive, and updated all the conf files accordingly using this tutorial https://stackoverflow.com/questions/8847392/how-to-change-xampp-localhost-to-another-folder-outside-xampp-folder.

I edited php.ini so that memory_limit and max_execution_time was higher. I also changed max_upload_size

  • Have you done any research to see if others have had the same issue as you? – Lodder Jan 15 '17 at 19:12
  • I can't find anything anywhere, I've been looking for a good few hours now. The information I find shows it freezing during the table creation phase, but my install doesn't even get to that screen. – Eoin Jan 15 '17 at 19:13
1

I would say this is related to the port change that you have on your system. Maybe there's another place that you will need to change that port.

Try the following:

  • Use Chrome for the installation, and check the error console. It might be that Joomla's ajax is trying to connect somewhere at port 80, but failing.
  • Check your server logs for any connections on port 80 - this will give you an idea which script is trying to connect to that port.

If you can't find anything, then try to run the server at port 80 and see if that fixes the problem (use a different browser, as the previous browser might have saved some environment settings).

2

I had the same issue to fix follow following steps:

joomla folder\installation\sql\mysql and open Joomla.sql file find the term "ENGINE=InnoDB" and replace ALL with "ENGINE=MyIsam"

MyIsam is more supported and compatible with Joomla.

I found this answer somewhere and it solved my issue, may be of help to you. If you have a better answer please update here.

1

I had this issue one time and seems that is a memory issue. Try to set a higher value in your php.ini memory_limit parameters.

memory_limit = 1G

Then restart your apache or php-fpm services.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.