0

I can't seem to find an answer to this, so was hoping the community could help shed some light. I have an editor.css set up and the styles are available in the dropdown when creating a K2 item. Brilliant!!

Although, the actual styles do not show in the admin editor screen, but if I apply the style and save the item then view it in the front end the style is correctly displayed.

Is there a way to display the custom styles on the text in the admin editor so that they match the styles in the front end?

For example, there is a style called 'cred' with the following in the editor.css

.cred{    font-style: italic;    color: #8C8C8C;}

The text when created in a K2 article by logging into the admin part of the site is not italic, thus the customer keeps thinking the style is not being applied and manually applies the italic when creating the item. However, it shows as italic on the main site without any intervention, thus he does not need to apply the italic.

I hope ive explained that well enough. I just want the backend styles to display as they do in the front end.

Any ideas? Regards Donna

  • Are you using the same Editor Profile for both K2 and the front end entry? That would be my thought, is that your front end Profile has the custom styles applied, but the admin editor does not. – Faye Jan 4 '17 at 18:08
  • Thank you for your response, as far as I can see yes. I have gone into the JCE component, then to Editor profiles > Default (this is the only one published). On the setup tab the profile is assigned to both front-end and back-end and the 'All components' box is checked. The editor.css path is showing in the Custom Css field under editor parameters. I'm stumped...Any additional suggestions? – Dtorr1981 Jan 5 '17 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.