0
/**
* @package Joomla.Site 
* * @copyright Copyright (C) 2005 - 2015 Open Source Matters, Inc. All rights reserved. 
* @license GNU General Public License version 2 or later; see LICENSE.txt 
*/ 

if (version_compare(PHP_VERSION, '5.3.10', '<')) { 
   die('Your host needs to use PHP 5.3.10 or higher to run this version of Joomla!'); 
}  


/**
 * Constant that is checked in included files to prevent direct access. 
 * define() is used in the installation folder rather than "const" to not error for PHP 5.2 and lower 
 */ 
define('_JEXEC', 1); 
if (file_exists(__DIR__ . '/defines.php')) { 
    include_once __DIR__ . '/defines.php'; 
} 

if (!defined('_JDEFINES')) { 
  define('JPATH_BASE', __DIR__); 
  require_once JPATH_BASE . '/includes/defines.php'; 
} 

require_once JPATH_BASE . '/includes/framework.php'; 
// Mark afterLoad in the profiler. 
JDEBUG ? $_PROFILER->mark('afterLoad') : null; // Instantiate the application. 
$app = JFactory::getApplication('site'); // Execute the application. 
$app->execute();
  • PS I have checked with my host and they have the appropriate version etc. Also nobody has touched my website for at least 6 months so I don't know why this has suddenly occurred! – B.Smith Dec 23 '16 at 2:19
  • 1
    Your version of Joomla is saying that it requires PHP 5.3.10 or higher to run. Based on your error msg, it would seem that your host is using a PHP version less than 5.3.10. – TryHarder Dec 23 '16 at 4:56
  • 2
    Updgrade your PHP version!!! There's absolutely no reason why you should be using anything under 5.6. – Lodder Dec 23 '16 at 8:59
1

The code that is echoed here:

 if (version_compare(PHP_VERSION, '5.3.10', '<')) { die('Your host needs to use PHP 5.3.10 or higher to run this version of Joomla!'); } 

Shows that your Joomla installation is trying to use a version of PHP lower than what it needs. If you have cPanel access you can change this yourself in the section at the bottom with the icon "PHP Version" or something similar. Otherwise contact your site support and ask them to upgrade your PHP to a newer version. Joomla supports PHP 7 and it is fast becoming the default on many hosts so that would be my recommendation.

1

To verify what version you are running create a new php file named phpinfo.php and include the following line of code in it:

<?php phpinfo();?>

Upload it to your server then to to yourdomain.com/phpinfo.php

That will show you definitively what version you are running.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.