1

So, I recently updated to version 3.6.5. I initially tested the update on a test server before moving the update to my live server. The issue I'm running into is Mysql 1273 Error

CREATE TABLE `zyjgk_assets` (
`id` int( 10 ) unsigned NOT NULL AUTO_INCREMENT COMMENT 'Primary Key',
`parent_id` int( 11 ) NOT NULL DEFAULT '0' COMMENT 'Nested set parent.',
`lft` int( 11 ) NOT NULL DEFAULT '0' COMMENT 'Nested set lft.',
`rgt` int( 11 ) NOT NULL DEFAULT '0' COMMENT 'Nested set rgt.',
`level` int( 10 ) unsigned NOT NULL COMMENT 'The cached level in the nested tree.',
`name` varchar( 50 ) COLLATE utf8mb4_unicode_ci NOT NULL COMMENT 'The unique name for the asset.\n',
`title` varchar( 100 ) COLLATE utf8mb4_unicode_ci NOT NULL COMMENT 'The descriptive title for the asset.',
`rules` varchar( 5120 ) COLLATE utf8mb4_unicode_ci NOT NULL COMMENT 'JSON encoded access control.',
PRIMARY KEY ( `id` ) ,
UNIQUE KEY `idx_asset_name` ( `name` ) ,
KEY `idx_lft_rgt` ( `lft` , `rgt` ) ,
KEY `idx_parent_id` ( `parent_id` )
) ENGINE = MYISAM AUTO_INCREMENT =362 DEFAULT CHARSET = utf8mb4 COLLATE = utf8mb4_unicode_ci;

Googling around suggests that there is some sort incompatibility between the Mysql versions on the test and live servers, so how do I proceed from here and fix this?

  • 1
    The answer may be in the the answer I answered for you in this other question that you ignored. joomla.stackexchange.com/questions/18642/… I suggest if you keep asking questions and want help that you should asknowledge those who try to help you. – norcal johnny Dec 18 '16 at 18:02
  • @norcaljohnny sorry for taking so long to acknowledge your post, I have been playing "whack-a-mole" with issues and trying to address these and other problems around a busy schedule. I'm sure you can appreciate how life can get in the way of things. I appreciated your well-illustrated post, but as I stated in my reply, your proposed solution wasn't an option and I will have to use part of your solution (look for a back up) as part of resolving all of this. In fact, the second poster spotted the DB table issues as a possible solution to move forward, and I will have to evaluate that. Thanks! – nizz0k Dec 19 '16 at 8:05
1

If you have a SQL file that you're uploading to phpMyAdmin, then try doing a find and replace. Replace utf8mb4_unicode_ci with utf8_general_ci, and then replace utf8mb4 with utf8, and then try uploading the file again.

Note: the above is not tested - but it should work. If possible, please post back your findings here so that others can learn from your experience.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.