2

I've recently run into a strange issue after upgrading to 3.6.5. I've been trying to resolve issues with a failed one-click-update to my live site.

Thankfully, I had a pre-updated backup living on a test server. I synchronized the content and then ran the updates on the test server. When I copy the code base and db to my local machine, the site and content are correct, but when I go to Extensions => database I get notified that the database is not up to date and there are errors.

I'm really perplexed as to what is happening here, because the site is fine on the test server, but has database problems on my localhost setup. Theoretically, there's no reason for this. I don't want to move to the db to live site until I know what's going with this.

  • Still any problems? Do you have the same configuration on all three sites? – Tom Kuschel Feb 9 '17 at 22:02
  • No, I solved it with a work-around. I ended up synchronizing the content with the test server and running the updates there and copying and moving that database to the other machines. I usually use a dev, test, and live set up; but I'm lazy about synchronizing content and typically only use the test site to demo content/implementations that aren't ready for the public. The live server is on a shared host, so I'm not 100% able to recreate the environment, but I haven't had any problems with using my ubuntu dev machine and test server so far. Backup, backup, backup – nizz0k Feb 10 '17 at 9:44
2

One of the last steps in the update process is to apply any schema changes, after files are copied in. If the one-click update fails, then the schema changes might not have been applied.

This will result in warnings that your database is not up to date with the code.

Navigate to Extensions > Manage > Database. If this is the problem, then you should see a warning message. The "Fix" button in the upper left corner ensures that all database changes have been applied and should resolve the problem.

Failing that: backups, backups, backups. is exactly correct.

0

Try the Fix button in the upper left corner. Often worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.