3

So, I'm trying to set up intro text for some of my articles displayed on a page by the Article Newsflash Advanced Module. I'm using joomla 3.6.

I want to be able to include images in the intro text on the main gallery page. The images are just small country flag png files. The issue is that it seems that images are stripped from the intro text somewhere along the line. So, how can I go about adding an image to the intro text?

I'm using Joomla 3.6 with the Article Newsflash Advanced module. The issue is that I add an image (.png) to the intro text (i.e. the text above the red "read more" hr it isn't shown in the intro text for the article (i.e. on text is displayed on the page with the Article Newsflash module. When I place the same image below the "read more" line it displays correctly within the article on the article page. From what I can tell, the module's layout code just echoes out the "item->introtext" into the intro text div on the page itself.

  • Are you using the default com_content component for articles? – Michael Yaeger Nov 28 '16 at 18:26
  • What template are you using? – webchun Nov 29 '16 at 10:06
  • Newsflash Article Advanced is this: extensions.joomla.org/extension/articles-newsflash-advanced ? And I am still getting confused when you later say that the image is showing/not showing in the article - You mean the com_content article view or the output of the module? – FFrewin Nov 29 '16 at 10:42
  • that's the correct module, sorry I glossed the title. And the template is theme 1498 from Template Monster – nizz0k Nov 29 '16 at 10:42
  • Hi FFrewin, I mean the output of the module. The intro text is hidden, so the image is not displayed on the article page itself. – nizz0k Nov 29 '16 at 10:55
2

I've had a very similar problem. If Article Newsflash Advanced was displayed inside a tab from Bootstap Tabs module, then you have to open Item Settings tab of this module and set Show Content Images setting to Yes.

  • You might have solved my problem! I’ll check and accept a little later! Thanks!!!! – nizz0k Nov 28 '17 at 12:17
  • life saving help here – nizz0k Dec 5 '17 at 11:04
1

If you can still find the image that you added to the introtext, when you open the article to edit with the editor, then the image isn't getting stripped from saving into the database.

Now, the information you provided is not clear and sufficient. For example we don't know what you are using to display the articles / where you are expecting to see that intro-text image - and anything else about your configuration/setup. Certainly a link to the page with the issue would help us to help you.

So some possible situations with a long shot are:

  1. You are using a content module that indeed strips out the images and likely other or all html mark-up from the introtext.

  2. You are using a template override for the blog layout that removes hmtl from there.

  3. It could also be something like a css rule that is hiding those images.

If nothing from the above describes your case or you are still not sure, then provide more info.

  • added context above – nizz0k Nov 29 '16 at 9:48
-1

1.open toggle editor for article.
2.add this line into your code.

<img src="media/mod_languages/images/hi_in.gif" />

3.you can add any flag by just changing hi_in by another flag.

the output will be as follow
enter image description here

  • hi @hemant, sorry I'm replying so late to this, but this didn't seem to work. This rendered the flag within the article editor, but nothing was rendered on the actual page itself. Also, because the images in the mod_languages page are limited to the language extensions for joomla they don't over all of the world's flag, like say Rwanda... – nizz0k Jan 13 '17 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.