4

After the joomla update the menu item seems to be broken. In every url I see

websitename.com/Clients/menualias

rather than

websitename.com/menualias

However, I resolved the issue by clicking the Rebuild button on menu manager. After which, every menu item works correctly. But now my problem is that when I create new menu item, it gives the same error of adding clients to the url. Then again I have to rebuild and it works.

For example, if a menu item alias is user-profile then Joomla system stores the alias correctly in database but the path is stored as Clients/user-profile

Is there any way by which the menu url can be fixed for the new items as well?

Joomla Version: 3.6.4

  • Hi, ¿Have the new menu as parent a "client" menu? – Piero Marsilio Nov 17 '16 at 10:41
  • no Clients is not any menu item. Don't know from where it is coming. I updated the question with the example. – Liz. Nov 17 '16 at 11:18
4

I had the same issue with the menu then I found this.

https://forum.joomla.org/viewtopic.php?f=615&t=772029

It was helpful but not the solution.

Then I checked my #__menu table and there I found com_banners_clients and this was creating the issue.

I simply deleted that row and it worked for me. You can check its level and if you will fix the levels then the issue will be resolved.

Note : deleting this row may effect only one thing that you will not be able to see sub menu in Banner component at admin side.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.