I want to hide a menu item to registered users, but when I use "Guest" access that item disappears! so no one can see it.

3 Answers 3


Please check that in User->Manage->Options that the value of the field Guest User Group is set to Guest.

  • it was public, I've changed it to guest and it worked....thank you so much
    – Heba
    Commented Nov 3, 2016 at 9:01

I know this is an older question, but I stumbled across this asking the same question as above. I was running into the same page display issue with the "Guest" access permission. While the answer above was helpful, it did not accomplish the outcome I was looking for, right now I'm currently working on Joomla ‎(3.9.19). I found that I didn't need to change the page permissions at all, and if you go to "Menu>Main Menu>(Select the page you wish to hide)>Link Type>Display in Menu Switch to No." It will hide the page from a registered user's menu.

I'm not sure if this option was available at the time of the question was asked. But it is now, and I was able to accomplish the exact outcome I was looking for, which was to hide a menu item from a "Registered" user's menu while still allowing a "Registered" user to access the page via a dashboard button I created. Previously, when I had changed the user permission to, "Guest" the "Registered" user was getting a 403 error when clicking on the button I created that linked to the page I was hiding in the "Registered" user's menu. Display in Menu Switch reference


This its the same answer from @Piero Marsilio, but with visual tutorial.

4 - Check if "Guest User Groupr" is set to "Guest". Thanks Pierro!

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.