3

I have to update a Joomla 3.4.7 site. I did first a localhost update to test - everything worked fine.

But now on the live site I am not able to login in the front-end. I am getting the invalid security token issue. Backend login works just fine.

I re-installed Joomla through com_joomlaupdate and generally have tried anything I could think to address the issue, but still nothing.

I did the same with manual installation but again the issue remains.

Is it possible that I am not using the right package? Reviewing the documentation:

It's not that clear which package I should use.
Anyone with ideas?

3

Solving my issue

Well in my case the issue was not related to Joomla core. I had to step away from it for a while and return with clear mind to find out that it was a custom directive inside the htaccess that was causing this issue.

It looks like someone wanted to prevent access to the com_users component in the front-end.

RewriteCond %{REQUEST_URI} !^/administrator
RewriteCond %{QUERY_STRING} \boption=com_users\b [NC]
RewriteRule ^ - [F]

Removing this - solved the front-end login issue.


Update - Front-end Login using Modules

For anyone that reaches to this page with this front-end login issue, I have noticed that using some login modules for front-end login may produce the above issue.
In this case make sure your login modules have their cache setting to No-Caching (disabled).

I am not sure for the core login module - but have seen this with 3rd party ones.

  • 1
    Wow, what an odd thing to add. Glad you found the issue – Lodder Oct 27 '16 at 16:50
  • 2
    @Lodder: it bugged me that much... you know when facing a problem, the problem puts a cloud around it - and sometimes the solution can be just next to you. That happened with me - I tried everything and never thought to check or disable the htaccess - I was using the same one I found on the site as is. After taking a break for a nap - I returned fresh and managed to think clearer. In the next 10 minutes it was resolved. So best advise when a solution isn't looking close - take a break away of the problem. – FFrewin Oct 27 '16 at 17:16
1

The invalid security token was an issue in the Joomla 3.6.1 update. To fix this, please see my answer here, which also caters for user who have Akeeba Backup installed:

https://joomla.stackexchange.com/a/17357/168

The package you need to be using for the update is this:

Joomla_3.6.x_to_3.6.4-Stable-Patch_Package.zip (direct download link)

Hope this helps

  • hmm, do you have any page caching enabled? – Lodder Oct 27 '16 at 10:04
  • no cache enabled - this thing is bugging me for second day now... – FFrewin Oct 27 '16 at 10:07
  • Someone had the same problem as you but was cache related somehow: github.com/joomla/joomla-cms/issues/12566. By the way, ere you sure you're site is now running on J3.6.4 now? – Lodder Oct 27 '16 at 10:10
  • yes 3.6.4 - but I started again from scratch and I am taking all the way up from 3.4.7 ... so right now I am at 3.6.0 - do you think the 3.6.0 to 3.6.4 package will work ? – FFrewin Oct 27 '16 at 10:57
  • 2
    I sorted it out. It wasn't Joomla - it was htaccess causing this. – FFrewin Oct 27 '16 at 16:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.