I tried all the other similar answers for the same error without success. I guess there are some kind of problem specific to the update on my host (GoDaddy). I tried:

  • Upgrade normally via backend (no success)
  • Upload the update package via backend / http (no success)
  • Upload the update package via ftp to the administrator/tmp folder (no sucess)

All these tries gives me the same error. Any other suggestions?

  • From your list, I see that you upload it to administrator folder and I don't think that is correct. Have you tried to upload to /tmp (root of your site, not administrator) folder and run the Joomla! update component? --- Edit: Check this manual, for another alternative.
    – cwps
    Oct 23, 2016 at 23:44
  • @cwps I tried to put the update package on the /tmp folder and after that I tried the update again, with the same result (error). I noted that the normal update method put the update package inside the administrator/tmp, so, I guess this is correct. I Will check the manual you tell me. TY Oct 24, 2016 at 1:44
  • @cwps The manual points three methods. The last two (B and C) are the supposed solution for me, but I do not like that. I will do some tests offline, on my local copy of joomla. Meanwhile I will wait for another answers. Thanks for the help Oct 24, 2016 at 1:49

4 Answers 4


I added slash before home in the configuration.php

public $tmp_path = '/home/host/public_html/tmp';

Finally I found the solution! The problem is that, for some reason, the Joomla was saving the temporary file to the "administrator/tmp" folder BUT the fopen function expects a fully qualified path, so I simply edit the Joomla configuration "Path to Temp Folder", at Server Tab, to include a full path to my tmp folder.

On another words, the Joomla can STORE files using relative path names, but relative path names cannot be read correctly by the fopen function and so, the update always fails. To fix, I used a fully qualified path name on the "Path to Temp Folder" configuration


Just upload the zip file to your Joomla website and extract it manually there. This is a manual update and it typically works smoothly when you are jumping to the immediate next version.

GoDaddy block a lot of functionality on most of their shared servers and that might be the cause of why you're seeing the problem.

  • I'm seeing that's the only way to get updated. I will need to do a complete backup before that Oct 25, 2016 at 20:20

trying to update joomla in localhost “ERROR: The archive file is corrupt, truncated or archive parts are missing” while

Goto configuration.php file edit
public $tmp_path = '../tmp'; to public $tmp_path = '/tmp';

The update will working file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.