Fresh install of Joomla 3.6.2 on Oracle Linux 7.2. Error displayed when attempting to load the site or admin area is " The file Cache Storage is not supported on this platform."


I have nginx 1.10.1 web server running configured with PHP-FPM 7.0.9. Apache HTTPD is not installed. PHP-FPM is running as user nginx:nginx. MySQL 5.7.14 is also running on a separate server and can be accessed by web server without any issues. Also note that the Joomla installation did not throw any errors.

What I have tried so far:

I have tried changing ownership of the 'cache', 'tmp' and 'administrator/cache' directories to nginx:nginx. They are all also world writable (for testing only). Finally, I have tried changing 'cache_handler' from 'file' to 'cachelite' in the configuration.php file, yet this error persists.

I am not sure what else to try and have not found any other workarounds/solutions to this problem.

Thanks to all in advance.


1 Answer 1


Update - this issue has been solved, here are the details.

It turned out this was due to SELinux (shocking, I know).

The thread I used to solve the problem is here

Thanks and credit go to L0ngN1t3 and Shain Rainville for his excellent post


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.