1

I'm trying to override the contact form. I've got two trouble:

  1. In mytemplate/html/com_contact/contact I've copied and renamed
    • default.php
    • default_address.php
    • default_articles.php
    • default_form.php
    • default_links.php
    • default_profile.php
    to
    • example.php
    • example_address.php
    • example_articles.php
    • example_form.php
    • example_links.php
    • example_profile.php
    Joomla show me the layout example in admin but it doesn't make any difference in the front.
  2. I've made an override in mytemplate/html/layouts/joomla/form/renderfield.php it doesn't make any diferrence too. I've noticed in components/com_contact/layouts/joomla/form another renderfield.php, which is the one applying to the contact form. I've got two questions/
    1. Why com_contact is not using the common renderfiel.php and the common renderlabel.php is used?
    2. How do I override this renderfield.php?

Does anyone any clues about that?

I hope you will forgive my poor english.

Thanks

1

I think you were copied the wrong file + wrong target folder too.

To override the com_contact you need to copy the file

.../components/com_contact/views/contact/tmpl/default.php

to

../templates/your_template_name/html/com_contact/contact/default.php

  • Thank you for your answer, but that exactly what i did. – Yaumes Nov 16 '16 at 5:57
0

First, check your browser dev tools. Most good templates will output the current view as a class to the <body> element which will confirm that you are looking at the correct view, e.g.:

enter image description here

Alternatively, disable SEF URLs in the site settings and the full path will be present in the URL.

If you are indeed seeing the correct view, i.e. from your template override, but not seeing your changes appear then you may be looking at cache. Disable caching in J! Admin and clear the cache then hard reload your browser.

  • Thank you but I've checked those points. I've added a class .test to default and it's default that applying – Yaumes Nov 16 '16 at 8:17
0

Try copy default.xml file as well (and rename), I think that it needs to be in override folder in order to override function properly.

0

I experience exactly the same. Additionally, if I place the adjusted override file back in the orignal tmpl folder (and rename it to default.php) the intended changes do occur.

Furthermore, the changes in the sub-files (i.e. default_articles.php) also in my_template/html/com_contact/ are handled correctly. So:

  • default override doesn't work
  • sub file override does work...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.