1

Hello I have custom joomla template: Demo is here

When I check source code for this template here is empty space before doctype html. I try to make:
  1. included helper file and here is no problem. (when I turn off included file empty space also is here)
  2. I check css and javascript files and problem not solved
  3. I check index.php file encoding (this is utf-8) and problem not solved
  4. them I remove html and php codes step by step from index.php and when here is no code problem solved. I can not understand where is bug.
2

My first guess would be a plugin or module that isn't properly written. If they contain whitespace or newlines outside of a <?php ... ?> tag it may leak into the template.

Since the issue isn't there when testing with Protostar (can be done by appending ?template=protostar to the URL) I would first check the modules. It also doesn't happen on all pages (eg the contact page is fine).

So disable all modules and then enable one by one and see when the issue starts.

| improve this answer | |
  • I disable all modules but problem not solved I can not understand what is this bug – Gocha Sep 17 '16 at 8:45
  • Maybe a plugin then, I'd start with content plugins. – Bakual Sep 17 '16 at 12:32
  • no i turn off all plugins that I have installed – Gocha Sep 17 '16 at 13:09
1

I found solution for this issue, the problem was in moduletable.php file after end of php code there was empty space, so I delete it and problem is fixed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.