0

Got a call from a client today who suddenly had these errors on the site, on Joomla 2.5.28

Screenshot of errors

Really interesting is - no one has made edits to this site in over a month, but these errors were not observed last week, and only started showing up this morning.

Even stranger still - System error reporting was set to None. It also appeared to have ground their K2 shop to a halt, preventing anyone from adding items to their cart.

I disabled the Koowa System plugin and everything seems to be working fine, including K2, but I'm very curious as to why this happened abruptly and if there's another way to address it.

Has anyone else experienced this or heard of it? Does anyone know of a reason why this could happen?

  • 1
    I've never encountered this error, but maybe your hosting provider updated the default PHP version? – Lodder Sep 6 '16 at 22:12
  • Oh, that's an interesting thought! Thanks for the idea I'll check on it. – Faye Sep 6 '16 at 23:05
  • If you are having issues other than "Strict Standards" warnings being displayed (like K2 not working), then there are other issues at fault. Warnings won't cause a site to stop working. Did you check the error_log? If so, were there any entries on or after the date the site started to malfunction? – Michael Yaeger Sep 7 '16 at 18:30
1

I had a very similar thing happen with a different component after upgrading the server's PHP version from 5.4 -> 5.5.

Essentially, Strict Standards warnings are not errors; they’re messages designed for developers to help troubleshoot their software and such messages don’t need to (and it’s recommended that they shouldn’t) be enabled on a production site.

To remove the warnings,

  1. Go to Site -> Global Configuration in the Administrator.
  2. Click on the Server tab.
  3. Set "Error Reporting" to "None" and save.

If that doesn't work, you can add the following line to your php.ini file:

error_reporting = E_ALL & ~E_NOTICE & ~E_WARNING & ~E_STRICT & ~E_DEPRECATED

Another option is to add <?php error_reporting(0); ?> to the top of your template's default.php file.

One of these solutions should work until the component's creator can make it "friendly" with your new PHP version.


References:

Solving the Strict Standards: Non-static method Joomla error

How to Fix Strict Standards: Non-static method in Joomla?

  • Sorry friend, that doesn't do it. As I said above, error reporting was already turned to none. I have the php.ini set up, still not working. Adding to the default.php is also a no go. – Faye Sep 7 '16 at 17:47
  • Which option doesn't work? All? I've seen instances where the Joomla! setting didn't have any effect, but changes on the server side did. – Michael Yaeger Sep 7 '16 at 18:27
  • None of those worked. – Faye Sep 7 '16 at 18:47
  • Ok, in that case, I'm going to say it's definitely a server setting preventing error reporting from being disabled. Sorry it didn't work for you. – Michael Yaeger Sep 7 '16 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.