0

I am using helix3 template, the menu item "home" is not taking "active class" when I'm on the home page or when I click on it although the other menu items are working fine, i want it to take the active class style and change its color when I am on the home page, it was working before!!

0

Try clearing your joomla cache. I also run into that problem with some templates if I have system cache turned on. So if that is on, I would try turning that off as well.

  • I cleared the cache and the problem remains :/ – Heba Sep 6 '16 at 9:03
  • Do you have system cache turned on? If so Turn it off and try again... Another thing that may work is, set both Search Engine Friendly URLs, Use URL Rewriting to NO. Then in the front end navigate to your home page. Then go back to the back end, clear cache and set Search Engine Friendly URLs, Use URL Rewriting to YES. – norcal johnny Sep 6 '16 at 9:07
  • it didn't work, but thanks anyway :) – Heba Sep 7 '16 at 8:50
  • Is it possible that you have a secondary menu that is pointing to the home page by accident? In other words is the main menu home link the one that is actually pointing to the home page and set as default? – norcal johnny Sep 7 '16 at 10:23
0

Go to "Helix menu Options" Tab and add the class there in "Custom CSS Class" It gives the class to "li" so it is better than the native Joomla class.

0

Add

!important

after the color value and it shall take precedence over other value that is stopping it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.