1

Joomla displaying wrong pagination

To explain with

a) say i am on page 24 the page shows below url

/index.php?option=com_news&view=list&Itemid=10&limitstart=115

b) Now when the com news list page opened / browsed again on the same browser

/index.php?option=com_news&view=list&Itemid=10

It displays content of page 24

However - when the page is tried and accessed on new browser - its displayed correctly

The cache is disabled, This is checked on chrome, firefox - all same

Basically any last page (say page 20) as browsed by user when explored in list view and again shown as default page in this url

/index.php?option=com_news&view=list&Itemid=10

This is browser

The first page has to manually be selected through How to solve it

Am on joomla 3.6.2, apache 2.4, php 5.6

Edited Though this is solved by destroying joomla session variable

<?php $session = JFactory::getSession(); $session->destroy();

Unsure how well is it Is there a way to kill only pagination session only

1

That is definitely a caching issue. Either you have the "System - Cache" plugin enabled, or you have some aggressive caching at the server level (if you are on a shared host, then note that some hosts are recently much more aggressive in their caching for shared hosting accounts).

Also, try renaming your .htaccess file to see if the problem is caused by some rules in your .htaccess file.

  • @ itoctopus - as checked the issue only pertains to same user in the same browser. Question edited, any thoughts - cache is disabled – Ruchika Aug 17 '16 at 17:20
  • Are you using any type of SEF? This problem can be caused by sh404SEF. – itoctopus Aug 17 '16 at 21:05
  • No its not by sh404sef as i am not using it, however i could find out that something related to session variable of joomla. As when i use <?php $session = JFactory::getSession(); $session->destroy(); - it works correctly. Is using session destroy a correct menthod – Ruchika Aug 18 '16 at 10:43
1

Open your actual Breadcrumbs module and make sure the caching is disabled there as well.

  • @ YellowWebMonkey - How to check if cache is disabled in it. I have re-edited the question as issue is with same user in same browser – Ruchika Aug 17 '16 at 17:24
  • Not sure if I understand your reply, I apologize if I am misreading. If you are asking how to check the individual module, go to Module Manager, open that specific mod_breadcrumbs, go to Advanced tab, and check Caching: awesomescreenshot.com/image/1493125/… – YellowWebMonkey Aug 18 '16 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.