1

My Joomla site breaks after I attempt to login in the front-end, returning an Error.

Error: 0 - Call to a member function get() on null

printscreen

I can´t see anything in the console, I dont have any further information where the error come from. This happens after I restored my site with Akeeba backup, everything was fine until the restore. I tried to restore other older backups but the issue still the same. I have checked the log and tmp path and they are ok, the folders and files permissions are ok to, at last I have repaired the DB in the Cpanel but the problem persists. I dont know what to do more. The weird thing is that I still can make the login in the back-end without no problems. I´m confused. I dont have 50$ to buy a subscription in Akeeba, so i use the free version, thats why I need some help, because akeeba only give assistance to the pro version. I have joomla 3 running in php 7.0.9 version

Any help will be apreciated.

  • Have you tried contacting the Akeeba developer? – Lodder Aug 6 '16 at 16:46
  • They only respond to those who have a paid subscription. And even these, they are slow to respond. still I do not have access to the Akeeba developer email. – legolax Aug 6 '16 at 16:58
  • Was this a restore to the same location where the website was working before or a restore to a new location? Maybe try switching back to PHP 5.6 or similar to see if the issue persists. Update all third party extensions to the latest versions. Check whether all third party extensions are PHP 7 compatible: docs.google.com/spreadsheets/d/… – Neil Robertson Aug 6 '16 at 23:29
  • 1
    Yes! I did that, problem solved. I change the PHP 7 to 5.6 and everything is ok now. – legolax Aug 7 '16 at 0:19
2

It's likely that you have an extension that is not compatible with PHP 7 yet.

Try:

  • switching back to PHP 5.6
  • upgrading all third party extensions to the latest versions

See https://docs.google.com/spreadsheets/d/1HJj02l3ByBvJF-Q67XXuGmrFvS8iIBEnDEcVcmwqzLc/edit?pref=2&pli=1#gid=0 for which extensions are compatible with PHP 7.0.

As far as I am aware, this document was created by Radek Suski.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.