0

I updated my joomla site from 2.5 to 3.6 with joomla core update component.

First, I updated joomla 2.5 to last version (2.5.8) and update extensions to last versions. and then update joomla to 3.6

but during updating process shows me below error:

Warning: require_once(C:\xampp\htdocs\projectname\libraries/import.legacy.php): failed to open stream: No such file or directory in C:\xampp\htdocs\projectname\administrator\includes\framework.php on line 15

and:

Fatal error: require_once(): Failed opening required 'C:\xampp\htdocs\projectname\libraries/import.legacy.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\projectname\administrator\includes\framework.php on line 15

How can I solve this?

1

As per the advice at https://www.joomla.org/announcements/release-news/5666-the-joomla-3-6-1-update.html, Joomla 2.5.x needs to be migrated to 3.5.1 at which point you can use the Joomla Update component to upgrade to 3.6.0 and then 3.6.2 or later.

To migrate Joomla 2.5.x to 3.5.1 specifically, you will probably have to use a manual update process as per https://docs.joomla.org/Updating_Joomla_(Manual_Method) or https://docs.joomla.org/J3.x:Upgrading_from_Joomla_3.4.x_to_3.5 or similar.

You can find the 3.5.1 release at: https://github.com/joomla/joomla-cms/releases/download/3.5.1/Joomla_3.5.1-Stable-Full_Package.zip

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.