1

I keep on getting the error 'Could not instantiate mail' in an module called Koparent that I use for my booking system in Joomla. At first I thought it might just be an issue with Koparent, then I searched around and found that it's likely an issue with my Joomla settings, see below.

Can someone please help me fix this

joomla settings

error message

  • if you are on Joomla 3.4.1 upgrade immediately. - make sure you have a tested and workable backup in place first. – FFrewin Jul 14 '16 at 8:43
  • @ffrewin, do you think this is the cause for the error? – Carltonp Jul 14 '16 at 9:15
  • no I don't say so - i m just saying 3.4.1 is outdated and vulnerable – FFrewin Jul 14 '16 at 9:41
  • Since you are having errors changing the Global configuration, I recommend changing via FTP to SendMail and SMTP and see if error persists. Also, in FTP, go to /libraries/phpmailer/ and make sure the folder exists. I had it somehow disappear on one site and just had to re-upload from core Joomla download. – YellowWebMonkey Jul 14 '16 at 16:21
2

I suspect the problem is the server you site is on doesn't allow sending on behalf of emails not registered or that server and therefore fails.

Make sure the from email is a real email address which is on the server of your site.

1

Seams like your server doesn't support phpmail.

You can try to switch to an alternativ method like "sendmail" or "smtp"

You can also use the "Send Test Mail" button below the settings to test them.

More info about the email configuration in Joomla : https://docs.joomla.org/J3.x:Global_configuration

  • Pierre, thanks for responding. phpmail was working a on the 22nd June, as I was able to send email. I can't say how long after that date it stopped working. I have tried 'Send Test Mail' with smtp, and sendmail but nothing works. Any other ideas? – Carltonp Jul 13 '16 at 20:37
  • I should mention that when I'm in global configuration mode whenever I attempt to make a change I get the message: The server encountered an internal error or misconfiguration and was unable to complete your request. As a result no changes are made. – Carltonp Jul 13 '16 at 20:39
  • Hello All, I have just tried to register on my site. I should get an email letting me that someone is trying to register, however I didn't get an email, therefore I dont think this problem is particularly an issue with Koparent. – Carltonp Jul 14 '16 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.