1

I have been having a few problems installing an application called DB Replacer. I keep on getting the error “JFolder::create: Path not in open_basedir paths Unable to create destination”

It was suggested that the solution to the problem could be found here: How to deal with "JFolder::create: Path not in open_basedir paths Unable to create destination" while installing Joomla extensions?

I have carried out the instructions to the point of opening Folder "libraries". However, I can't find that folder.

Can someone point me in the right direction?

Regards

Carlton

  • It's not possible to have a running joomla site without the libraries folder. It's located at the root of your Joomla installation. I hope this is the location you are looking at. – FFrewin Jun 28 '16 at 12:51
  • If you are reading this you may be tearing your hair out for months like I have. I have been installing Joomla in as many ways possible and have always come across the error that the base_dir cannot be found, installer packages cannot be found, then I came across this reply, and it was the simplest thing ever: The "/var/" was replaced by my provider with "/vdatas/" (or at least after the Joomla nstallation this was the case. FFrewin kindly put the tmp folder pathe for cPanel and Plesk and I noticed one difference to the default installed option, the "var" instead of "vdatas". So please check t – Joomla Rookie Oct 5 '18 at 13:10
1

It's not possible to have a running joomla site without the libraries folder. It's located at the root of your Joomla installation. I hope this is the location you are looking at.

Also, in the Q/A you linked, there is more than 1 answers. So make sure you read everything there. You could try the second answer as well, to enable Joomla FTP layer.

Additionally make sure all Joomla directories are writable, just in case you have any permissions issues. You can go into your backend System -> System Information -> Folder Permissions and look down the tree of your directories tree if all dirs are writable (green).

Joomla System Information - Directory Permissions

Finally you can ask for advice from your hosting provider, and maybe they could make the appropriate changes on the server/php configuration (maybe with a custom php.ini or in htaccess).

For example you could define your own value for open_basedir directive, to the appropriate location for your site like:

cPanel:

open_basedir = /home/username/public_html:/tmp

or Plesk:

open_basedir = /var/www/vhosts/domain/httpdocs/:/tmp/

In addition, if open_basedir is set, it may be needed to set also the PHP upload_tmp_dir directive to a path that's inside the open_basedir scope.

What will work for you depends on your environment, so your hosting provider should be able to assist you or give you the right information.

  • thanks for responding. The FTP option isn't viable as I don't have an FTP server. As regards permissions the only file that isn't writable is 'configuration.php'. Shall I make that writeable? – Carltonp Jun 28 '16 at 14:17
  • Actually, how do I make that writable? – Carltonp Jun 28 '16 at 14:17
  • I was being ad idiot. I followed the instructions from the link you provided (second solution) and it worked like a dream. Can't thank you enough. Cheers mate – Carltonp Jun 28 '16 at 14:29
  • @Carltonp: It's better to keep configuration.php as unwritable (444 permissions) - Only Folders make sure are writable (775 permissions). Glad if I helped. – FFrewin Jun 28 '16 at 14:34
  • I have just updated the original question that this question was generated from. I mentioned, DB Regular won't do the job as I had posted. This is a shame because it appeared really good - especially as I spent nearly two days trying to get it installed. – Carltonp Jun 28 '16 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.