0

Since I updated the JCE editor to the 2.5.16 version I've been unable to upload files via the File Browser. It always popup an alert window displaying:

The server returned an invalid JSON response

If I look into the JSON response from the developer tools I find a valid JSON string but with some html at the end that must be messing with the JSON parsing.

<\/a><\/span><\/div><\/li><\/ul><\/li><\/ul>"}<!-- l: nobody -->

I tried from different browsers, users, reinstalling the Extension, updating it to 2.5.17 and later to 2.5.18 and the issue remains.

I'm actually using the Joomla version 3.5.1

Has anyone faced this or knows what to do?

Thanks

  • Maybe report this to JCE developer – FFrewin Jun 23 '16 at 8:05
  • That was my first attempt but you need to purchase a subscription in order to place a question in the forum. And at this point I'm not sure if it's mainly a JCE issue or something in my Joomla / Apache configuration – Rash Jun 23 '16 at 8:18
  • You can contact them via email. You shouldn't have to pay to report a bug: joomlacontenteditor.net/contact/contact-administrator – Lodder Jun 23 '16 at 9:48
  • I gave it a shot, even if that link states Please do not use this contact for support requests or bug reports. but I got an email 5 minutes later addressing me to the paid support forum – Rash Jun 23 '16 at 10:56
  • Wow, I personally find that absolutely disgusting how they make people pay to submit a bug for their extension. Could you try taking a backup of your site, install it on a subdomain or localhost then try upgrading to Joomla 3.x? – Lodder Jun 23 '16 at 13:05
0

After some time searching for a solution, the only thing that "solved" the issue was to do a clean install and import the database and the files to it.

Restoring a backup to a subdomain or in a local server showed the same problem.

So I don’t really know what was going on, thanks for all your responses anyway

-2

Having the same problem, I used https url to login to admin. Although the SSL certificate is self signed in my server, that worked and the file uploading is working. Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.