2

IMPORTANT UPDATE I have finally been able to get in touch with the guy who was running the site prior to my taking over and he has told me he had stopped using Joomla and was just updating the pages directly. I am still unclear how the disconnect has happened as the Joomla does appear to be connected to the main site in some way - but clearly this is the reason why I was failing to get it to publish. It may be that in the future I will try to get Joomla running again on this site, but that is the topic for another question. Thanks to everyone who has helped, I'm sure these replies will be useful to those who have a similar problem. It seems I can't get the scores I add to answers to show up until I have been here longer, but I will try to mark all the answers that seemed to be helpful to me.

Thanks again for all the assistance.


I've taken over a website that uses Joomla, which I only have a very basic understanding of. I want to make just a small change to an existing published article, but the change won't show.

I'm using Joomla 3.4.6.

Here is the site Suffolk LGBT Network

Here is the article with the text I've changed: here is the text I have changed

I am sure this is the right article, so why isn't my change showing on the live site? I've been trying to get this to update since last Friday (4 days)!

Any help is very much appreciated.

The cache setting is OFF enter image description here

  • 1
    Currently the text says-"We have had a very busy Summer, and we are about to launch a series of new services:" If this is correct, then your browser or Joomla (or both) were caching the page. – TryHarder Jun 13 '16 at 23:48
  • Hi John, I believe it is about the cache thing. I don't know if this will solve your problem or not. Try to go to the "Global Configuration", and on "System" tab, find "Cache Settings". Try to set it as "No Cache", then save it. Once again, clear your joomla cache and your browser cache. If that works, I suggest you change it back to "Conservative Caching". What is that? Find it yourself :) – adadion Jun 14 '16 at 14:01
  • And oh, I see that you're new in StackExchange. You can post Answer, if it is the Answer of OP's Question. So, the right thing to do for answering people's comment is inside comment too, or you can edit your own question, and put your added information regarding suggestion from others. :) – adadion Jun 14 '16 at 14:08
  • 1
    Funny... nobody saw that this isn't a joomla site? – FFrewin Jun 18 '16 at 10:10
  • @FFrewin I didn't even check! If it were my site, I would obscure the fact that it was running Joomla. – TryHarder Jun 19 '16 at 3:08
4

In this case the article is loaded by the menu item home, check the correct article here.

Are you using some cache extension for your site?, check for possible extensions and
clear the cache.


Note: For security reasons, create a backup and upgrade your site to the latest version
available, at this time is J3.5.1.

  • Try clearing your browser cache too. – TryHarder Jun 13 '16 at 23:48
  • I am tempted to try updating to the latest version, maybe that will fix all these strange issues. That is something to consider, thank you. – John Jun 14 '16 at 10:25
  • Also check the permissions via FTP client or directly in your webserver, the correct values: 755 for directories and 644 for files. – AlejandroVega Jun 14 '16 at 18:17
  • I had a look at upgrading to the latest version but there are so many extensions/plugins and I don't know if they are compatible with it, so I am leaving it for now. I would rather just try to get this working. – John Jun 15 '16 at 9:39
2

Caching is my greatest enemy.

Step 1. Check Joomla Cache settings. (which you've done).

Step 2. Clear Joomla Global cache and purge, even if you don't see any changes. Just in case.

Step 3. Clear your browser cache.

Step 4. Check the DNS manager. For example, if you're using Cloudflare, there could be caching enabled. Purge the files, or disable caching.

Step 5. Your host might have caching enabled. Example, SiteGround. Flush the cache.

Step 6. Make sure you're really editing the right page. Go to the Menu Manager and look for the menu item of the page you're trying to edit. Confirm the single article is set to the article you've been editing.

Step 7. Make sure you're really editing the right site!!! Check your urls, double check your admin urls. Make sure you're not on a staging version or a dev version.

After all that, if you've ruled out your host, your dns, human error, browser cache and joomla cache...you'll probably need someone with a higher level of skill to get into the site and do some deeper digging.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.