2

I'm trying to figure out where in the heck is the "Written by" tagline displayed at the top of each news article...basically, which css/php/whatever file holds the layout for articles and would contain that. Somehow the name of the article's author isn't showing up next to "Written by," and I'm trying to find out why. I've tried a couple of things already:

1) Switching the global "Show/Hide Author" option does NOT work: there is absolutely no change in the "Written by" text, and the author's name is still blank. It also doesn't work in the Article options menu either.

2) I tried searching for the configuration/template file on Google...a couple of articles mentioned a content.html.php file in the com_content folder, but I suspect that must have been for an earlier version of Joomla, as I don't have that file (I'm using 3.x). As of now, I don't know whether it's a css file, php file, or something else.

3) I tried to do a search on the source code in my site folder using "Written by," but I only came up with two language .ini files. Taking the "Written by" text out of those didn't change anything, either. I also tried "author"...nothing of any substance resulted. I don't know of any other variable name or text to key in on.

I think I may have altered something in the past and that's why the author name is not showing up beside the "Written by," but I can't be sure. Besides, doing a "Hide" on the Global options should have taken care of what's left, regardless. I'm pretty much at my wits' end. Can anyone help me with this?

THANKS!

UPDATE: I FINALLY was able to make the "Written by" text disappear (it was an option on the menu setting...Joomla seems counter-intuitive at times). However, I'm still at a loss regarding why the author's name doesn't show up next to the "Written by."

  • Please add your solution as an answer so you can accept it and resolve this question. – Neil Robertson Jul 11 '16 at 1:26
2

If you want to show or hide author you dont have to hack the core files as there are predefined option in the administrator panel. Login to Administrator and click on Content article. You will find option on top right; click on that. You will find several options to display article. enter image description here

  • Hello @Amit_Ray...thanks for your suggestion! However, as I mentioned above, I already tried changing the Global options for showing/hiding author, but it had no effect, and I don't understand why that's the case. That's partially why I wanted to find out which core file(s) control the author being displayed, to see if there were any modifications done that disabled it there. – Superion Jun 10 '16 at 12:37
  • Have you checked to see if your template has a template override for that view (single article or category blog)? I would go to templates/YOUR_TEMPLATE/html/com_content/article and templates/YOUR_TEMPLATE/html/com_content/category, backup the files there, and then delete. Check to see if it functions normally without those. – YellowWebMonkey Jun 14 '16 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.