4

When setting up a Cronjob for smart search the links from search results goes to blank pages. When indexing manually everything works. What am i doing wrong?

Sending the command

php [URL]/cli/finder_indexer.php

Memorylimit 256 MB

  • The Smart Search, in its current incarnation, puts a lot of pressure of the website from multiple angles, it is a better idea to disable it and use Sphinx instead. See this comprehensive guide on how to do that: itoctopus.com/… . Using Sphinx instead of SmartSearch will reduce the load on the server substantially especially on high traffic sites with lots of content. – itoctopus Sep 12 '18 at 13:11
1

You should be executing that based on the file path, not a URL

Say the file is located in /var/www/html/cli/finder_indexer.php

Your cron job should execute: php /var/www/html/cli/finder_indexer.php

Running it manually, you should see output like this:

Smart Search INDEXER
============================
Starting Indexer
Setting up Smart Search plugins
Setup 5 items in 0.068 seconds.
 * Processed batch 1 in 0.311 seconds.
Total Processing Time: 0.38 seconds.
Peak memory usage: 10,485,760 bytes
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.