0

I would like to display the articles in the front end, without the print and email links.
I have configured the publishing article options in Joomla for that, both article publish links disappear. Supposedly I have adjust this setting in Global Options and in Content->Articles->ArticleFrontPage options and this links continue showing in the display.

How could it be reached?

Thanks in advance

2

I can't get where is the Content->Article->ArticleFrontPage options you are mentioning in your question.

Regarding the front-end display:
- Is this happening to a certain menu item? article?

Note that Global Article Options can be overriden by menu item or article settings.

Each article has its own Show Icons settings in its Options Tab. Following any of the articles menu items have the same settings in their Options tab.

So, I would suggest you to have a look at corresponding articles, menu items options, for which you still see the icons in the front-end.

Hierarcy

As regarding the hierarchy of the options:

Global Settings come first, Article settings will override the Globals, Category settings come next and Menu Item settings are last. So a Menu Item's settings will override everything.

Template Overrides

As a last note: if changing settings doesn't seem to result to a change in the front-end, it can be due to template overrides. You might have a template that is overriding the layout output of the com_content component. So it's worth checking in the html folder of your template for a possible override.

More reading:

There is another similar question in JSE:

These articles might be helpful in understanding Joomla Articles:

Template overrides

  • Yes, i have set the Global Article Settings and the Content->Article->ArticeX->Options Tab, and it continues showing the print/email Article links. "ArticleFrontPage" is the title of the article that i have published in the front page - At this moment i haven't any menu in the Home Page (FrontPage) – jgc412 May 14 '16 at 17:20
0

finally i accomplished to customize this setting, editing the icon.php file from the layout for the content component placed in my template folder: xampp-root-folder\htdocs\joomla\templates\ilus-design\html\layouts\joomla\content

web source: https://www.ostraining.com/blog/joomla/layout-overrides/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.