3

I am getting an issue with accessing Advanced Module Manager for certain usergroups.

On my manager user group - I have set the Global Access Administration Interface to inherited (resulting to not allowed calculated value), so I can selectively allow certain access to components etc later on.

So, now I want to give access to the module manager (which is replaced by AMM) to certain modules.

In the permissions of Module Manager I give to the manager group Access to Administration Interface, but yet when reaching to the AMM interface I get the:

You are not authorised to view this resource error.

Actually even if I grant Super User permissions on manager group for the Modules component, AMM still refuses to allow access.

Same time, there is no issue to reach to the core Module manager with that manager user account (option=com_modules).

The only way for AMM to allow access is to set the Global Permissions Administrations Interface Access for manager to allowed.

  • 1
    I think this is a good question, but I'd like to point out that the developer has suggested that bugreports and support requests regarding Regular Labs extensions go on the Regular Labs forum at regularlabs.com/forum I'm writing his comment here as I expect the answer (where it was originally written) will be deleted. – TryHarder May 11 '16 at 13:26
3

I tested to see how Advanced Module Manager works on a clean Joomla installation and I couldn't replicate the issue.

After messing around a bit more, I discovered that my issue was connected with the ACL Manager component, which was also installed.

Advanced Module Manager simply uses the ACL of the core Module Manager. But ACL manager will not follow this to apply the core permissions of Module Manager to AMM and will inherit permissions to AMM from the Global Permissions.

I had to go and manually add those permission inside ACL manager's permissions table for the usegroups I wanted and that fixed the issue.

enter image description here

This initially isn't very obvious: So here are the steps that are needed to enable the permissions to AMM through ACL manager.

  • Go in ACL Manager.
  • From Control Panel, click the usergroup or user that needs to have this special access to AMM.
  • In the User/Extensions Permissions list of the ACL manager, find the Regular Labs AMM component (or use the filter on top to help find it).
  • As shown on the above screenshot - AMM won't have enabled permissions by default both in Global and AMM permissions row. You need to click on the permission icon, to switch the state of the Access permission and set it to green.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.