1

So I locked myself out of the Joomla backend when I was messing with the user permissions...I finally got in using the public $root_user=’johnsmith’; in configuration.php, but when I logged in I can't see the Joomla admin menu to be able to go back in and change my user permission settings...how do I access the menu like I could before I locked myself out? enter image description here

Whenever I click the Joomla icon it just kicks me back to this main page. Any help would be greatly appreciated!!!

1

It looks to me like you are trying to access the back-end with an account that only has registered permissions - certainly, that's the screen I get when I try it with such an account.

As Joomla specify here, this method works with accounts that are Author level or higher.

If this is the case, and you have no known accounts with a higher setting, then you'll probably need to poke around in the database to reset it.

  • I am the only user and had a super user account, but when I set the user permissions I didn't realize that by denying every other user except super user, it would lock me out. So then I finally got in using that code in configuration.php to restore the user permissions to their original setting and now I can't see the menu. Do you know how I can reset it in the database? – Amy May 2 '16 at 22:12
0

Here are a couple of options to try:

1. Promote User to Superuser

Check that the user account you are logging in with is a member of the Super Users group.

Log in to cPanel and go to phpMyAdmin (or similar) and ensure that the group_id of the relevant user in the [your_prefix]_user_usergroup_map table is set to the Super Users Group ID which by default is 8.

You should now be able to log in with full privileges.

2. Add a New Super Administrator User

Assuming you have access to cPanel and phpMyAdmin (or similar), you can create a new Superuser in Joomla 2.5 and Joomla 3.x as per Add a New Super Administrator User in the official documentation:

  1. Navigate to phpMyAdmin and select the database for the Joomla! site in the left-hand drop-down list box. This will show the database tables on the left side of the screen.
  2. Press the "SQL" button in the toolbar to run an SQL query on the selected database. This will display a field called "Run SQL query/queries on database ".
  3. Delete any text in this field and copy and paste the following query below and press the Go button to execute the query and add the new Administrator user to the table.
  4. Use the SQL query below to add another administrator account.

Make sure you match your db table prefix!

The following code uses jos31_ as the table name prefix which is only an example table prefix. The prefix when you first installed Joomla is RANDOM or what you set it specifically too. You will need to change all occurrences of jos31_(your install set prefix) found in the code below to the prefix your installation is using.

INSERT INTO `jos31_users` (`name`, `username`, `password`, `params`) VALUES ('Administrator2', 'admin2', 'd2064d358136996bd22421584a7cb33e:trd7TvKHx6dMeoMmBVxYmg0vuXEA4199', '');
INSERT INTO `jos31_user_usergroup_map` (`user_id`,`group_id`) VALUES (LAST_INSERT_ID(),'8');

At this point, you should be able to log into the back end of Joomla! with the username of "admin2" and password of "secret". After logging in, go to the User Manager and change the password to a new secure value and add a valid e-mail address to the account.

  • I tried adding in that code into the SQL query and when I tried to log in I'm getting an error message that says "You do not have access to the Administrator section of this site." – Amy May 2 '16 at 23:34
  • OK, I have updated my answer with an additional option – Neil Robertson May 2 '16 at 23:47
  • I realized I had changed the id to something different, so I was able to get in. But do you know how I change back all of the user permissions to their default settings so I don't get locked out again? Thank you SO so much for your help!!! This almost cost me my job. I really appreciate it! – Amy May 2 '16 at 23:54
  • Rather than messing about in phpMyAdmin, it might be easiest to go to Users -> Manage and create a new Super User account. Once you have tested this and it looks OK, you can disable or just delete the old account. – Neil Robertson May 2 '16 at 23:59
  • So I have full privileges now but it's only when I still have public $root_user="username"; in my configuration.php file. When I deleted it I logged out and tried to log back in but was getting the same error message I was before. – Amy May 3 '16 at 0:01
0

To answer how to restore the original Joomla ACL user permissions, try the ACL Manager extension. You can open each level and hit the RESET button to revert back to original: https://www.aclmanager.net/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.