4

Background

My business website is using an appointments scheduler/shopping cart called VikAppointments so my dates/times are very important for smooth business operation.

My Timezone is Central European Time Zone UTC+01:00.

Problem

I am on a shared hosting plan with Hostgator and they have my shared server time set to America/Chicago | 2016-04-22 10:54:31 CDT

I tried setting my Joomla time to Central European Time Zone but when I go into VikAppointments the default Timezone is still set as

The documentation says the following:

Current Default Time Zone The default Timezone set on the php.ini configuration of your server. If this value doesn't correspond to the local area of your business, you should contact your hosting provider.

However hostgator says this about Timezones on shared accounts:

The server clock is set to Central Standard Time (CST). While you cannot change the time on a shared server's clock, you can change the time zone which is displayed by using a PHP script.

Question

Is there another way (perhaps adding some PHP to one of my root directory files?) to set my Timezone so that it will show up correctly in my Joomla Extensions?

Very grateful here for any heeeelp! :-)

update:

I have tried a whole host of things

Currently I have the following code added to my .htaccess file in the public_html directory...

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
SetEnv TZ Europe/Paris
## End - Custom redirects

But it changes nothing (and I have Apache ReQriting turned ON).

I tried the answer below for the .htaccess (I cant access my php.ini file because I am on shared hosting!!) and it gives me 500 internal errors.

This is incredibly difficult!

update II and solution!

Well that was complicated but it works.

Steps I took:

1 - Created a new php.ini file and added it to my home root folder. 2 - Added the following code:

date.timezone = Europe/Paris

3 - Important: updated my public_html/.htaccess folder with the following code:

<IfModule mod_suphp.c>
suPHP_ConfigPath /home3/username_here
<Files php.ini>
order allow,deny
deny from all
</Files>
</IfModule>

I recommend reading the Hostgator article on php.ini: support.hostgator.com/articles/what-is-php-ini

And voila. Thanks so much for your help!!

  • I would suggest contacting the developer of VikAppointments. It's quite possible they're not calling the timezone from Joomla's Global Configuration, but the server's instead using native PHP – Lodder Apr 22 '16 at 17:02
  • Good idea, seems like the only practical answer other then moving to a dedicated host (which we might also do!) – Jethro Hazelhurst Apr 22 '16 at 20:11
5

You should be able to set the default timezone via php.ini or .htaccess.

Set Default Timezone via php.ini

Add the following or similar line to your php.ini file:

date.timezone = "Europe/Paris"

You can create the php.ini file in the root folder of your website if it doesn't already exist.

Set Default Timezone via .htaccess

Add the following or similar line to your .htaccess file:

php_value date.timezone "Europe/Paris"

If neither of these options works, you could try contacting your hosting service provider for support.

  • I updated my comment, still not working unfortunately as I am getting 500 errors. – Jethro Hazelhurst Apr 23 '16 at 13:37
  • Answer also updated! – Neil Robertson Apr 23 '16 at 13:47
  • Outstanding Niel, going to try everything right now. Very interesting. – Jethro Hazelhurst Apr 23 '16 at 14:01
  • 2
    Neil that was fantastic advice, my answer has been updated as there was an extra step I had to do to get it to work. Thanks again. – Jethro Hazelhurst Apr 23 '16 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.