2

While trying to update my Joomla instance on my native environment in OSX Yosemite 10.10.5. I am brought to the "updating" page where the progress bar shows up and a message that says 'Updating your Joomla files. Please wait ...' but nothing happens. I looked in my server log files but found nothing unusual, however I do get an error in the browser console on the 'updating' page that says -

Uncaught TypeError: window.pingExtract is not a function
  • I would just clear Joomla and browser cache, restart browser and tried again. – Mikan Apr 7 '16 at 7:44
  • Tried all these things with no luck – handofjobin Apr 7 '16 at 12:51
  • Found out something here but have not a solution, have you tried now with Joomla 3.5.1? Have you tried to just leave the browser for a long time on "Please wait.."? It could be processing the update but not showing progess bar due to the javascript error. – Kitase88 Apr 8 '16 at 9:44
  • I tried both 3.5 and 3.5.1 but no luck. I did find this link which describes my problem exactly. – handofjobin Apr 11 '16 at 15:52
4

I had the exact same issue on two 3.5.0 instances.

Turns out that media/com_joomlaupdate was missing the /js directory. The file update.js in the /js directory is what declares pingExtract

I downloaded the full package of Joomla extracted the directory and placed it where it in media/com_joomlaupdate and it resolved the issue.

  • Sorry for the late reply. I tried adding the JS directory and to the com_joomlaupdate folder and ran the updater again. I ended up getting a different error message than before having to do with my database configuration. I was on a tight deadline so I created a new Joomla instance and moved my template over. Any idea why the folder went missing? – handofjobin Apr 15 '16 at 1:30
  • My guess would be something to do with the updater Joomla when I updated to 3.5. Maybe the updater removed the directories but failed to apply fresher copies? Since I performed the same update on two separate instances and the got the same results I am willing to bet it has to do with the updater/how I perform updates. Glad you got a solution working though! – CWilhel Apr 19 '16 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.