4

I have a ton of sites on my server and they range from Joomla 1.5 to 3.5 but now I've been asked to upgrade to PHP 7 compliance for my Joomla 3.5 extension that I sell.

Will the 1.5 site work on this version of PHP?

4

You can find previous answer here on JSE:
What is the maximum version of PHP that Joomla 1.5 will run?

There are also official Joomla Technical Requirements which lists Recommended minimum PHP 5.3.10, but not max version.

Based on my own experience, Joomla 1.5 will work on MAX PHP 5.3.29. Depending on extensions used, I was able to run it on even PHP 5.4, but I still prefer to think of PHP 5.3 as Max Version for stable runs of this old version of Joomla.

I am afraid IT WILL NOT WORK on PHP7.

4

PHP 5.6 is as far as you can go with Joomla 1.5 (depending on the extensions you are using) and you have to suppress strict standard warning messages etc.

Depending on your hosting environment, you may be able to configure different PHP versions for each of your Joomla installs.

This is fairly easy to do via the PHP selector tool in cPanel on SiteGround shared hosting accounts, for example.

On other hosts, this can sometimes be achieved via a directive in the .htaccess file.

  • 3
    Or with addhandler x-httpd-php53 .php directive in .htacces file – Mikan Mar 25 '16 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.