3

How do I remove the "Ordering" drop-down menu option from Joomla Search?

I need to remove the Green highlight section not the Red section by setting 'Use Search Options' to 'No'.

Thanks!

A Screenshot of the area I wish to remove

  • For a Joomla template "theme1616" how would you accomplish this? In terms of getting rid of "Search For:" and "ordering". – Lavinia Apr 6 '18 at 0:05
1

Search Options

Setting Components -> Search -> Options -> Use Search Options to "No" will disable the search options.

CSS Override

Alternatively, you could hide the ordering option this via CSS as follows:

.ordering-box {
    display: none;
}

or possibly:

.ordering-box {
    display: none !important;
}

This may depend on the template you are using. For example, this seems to be correct for the JSN Solid Pro template if the demo is anything to go by:

JSN Solid Template Search Option

Taking JSN templates as an example, copy the custom CSS code into a custom file e.g. custom.css and copy the file to the CSS folder at /templates/[template name]/css. Remember to specify the name of the CSS file at Extensions -> Templates -> [template name] -> SEO & System -> Custom CSS/JS File(s).

See https://joomla.stackexchange.com/a/3878/120 for instructions on adding custom CSS files to other templates.

  • I had already set my 'Use Search Options' to 'No', removing the section highlighted in red in the new screenshot. But I need to remove the 'Ordering' drop-down menu highlighted in green in the new screenshot. I tried placing in the suggested CSS into my custom.css but it did not remove the 'Ordering' section. Do you have any other advice? Thanks! – mrbuckmccoy Mar 9 '16 at 20:36
  • It might help to say what template you are using or ideally post a link to your website. – Neil Robertson Mar 9 '16 at 22:12
  • 1
    Yes, sorry about that. I am using JSN Solid Pro template, joomlashine.com/joomla-templates/… . But unfortunately my site is a internal portal on the company network so I cannot provide access. But any suggestions you can offer would help me and my team so much. I really appreciate your help on this! – mrbuckmccoy Mar 10 '16 at 2:20
  • Check that your CSS override is active by browsing to your custom CSS file at http://[your-web-site]/templates/[template-name]/css/custom.css or similar to confirm the code is present. You may need to clear the Joomla cache etc to ensure that the latest version of the custom CSS file is loading. – Neil Robertson Mar 10 '16 at 4:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.