2

I built a new site in Joomla 3.4.5 with JCE editor 2.5.11. When I tried to upload an image in the JCE's image dialog, it failed with "Upload Failed: No Data". Unlike this case, this error occurs for every image, not just some. I checked in the source code (row 823) that JCE thinks the image file is empty, so it probably fails before reaching the JCE file check.

So I tried to upload the image in backend (media manager). In complains about files being too big instead. The limit is set to 10MB and I tested this with image files of several tens or hundreds kB, so there must be some bug. But how to correct/ workaround it?

EDIT: after upgrade to Joomla 3.4.8 and JCE to 2.5.14, the error message in the frontend changed to [object Object]. The error in the backend is still the same.

  • Why would you build a Joomla site with an old (and vulnerable) version? First, start with the latest Joomla and JCE Editor. Review System Information / Permissions. – Anibal Mar 5 '16 at 8:21
  • @Anibal: I installed it with 3.4.3 several months ago and didn't have time for testing a backup since then, so I was afraid to upgrade. Now I checked again and I did some upgrade, it's 3.4.5 now. Joomla 3.4.5 and JCE 2.5.11 isn't so old, is it? I take it as an encouragement to backup and upgrade my site though, even if connection with this bug was unlikely. – Pavel V. Mar 5 '16 at 9:20
  • @PavelV. There have been security vulnerabilities that are easily exploitable with recent versions of Joomla. You should update to 3.4.8, which fixes them all – Lodder Mar 5 '16 at 11:48
  • 1
    Are you seeing a javascript error in the browser Error Console when attempting an upload? Have you clear you cache browser? – Pierre-André Vullioud Mar 5 '16 at 20:26
  • 1
    @PavelV. Please also update JCE Editor to the latest version (2.5.14) as the issue you have may have been fixed. – Lodder Mar 5 '16 at 20:37
3

@Lodder and others were right that the answer was to keep site up to date and be patient. The error was corrected in JCE 2.5.15.

| improve this answer | |
  • Glad it was as simple as a quick update :) – Lodder Mar 15 '16 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.