1

My configuration: four separated (multilingual) joomla websites in one webspace. One of the sites in the root and three URL redirects pointing to maps containing Joomla 3.x installations. Each site contains a JCE. Only the editor in the site in the root functions flawlessly. The other three (redirected) show no icons and thus only raw HTML can be used. Tiny-MCE gives no problems. No Java or CSS compression. Can't find the solution to this problem, please help!

1

EUREKA !!!! the solution: When Joomla is installed it has SEF-URL (search engine friendly - URL) enabled. And don't ask me why but that caused the JCE not to function in the redirected sites. So disabling "search engine friendly" URL in Global Configuration restored JCE's Function. Thanks to the "Hyde-design" page that put me on the right track. References: http://www.hyde-design.co.uk/joomla-training/sef-joomla/urls-

  • 2
    I don't know mate... Disabling SEF URLs is not recommended practice to begin with, but if makes you happy, who am I to complain... – Mikan Feb 4 '16 at 15:14
  • I've been longing to ask you the minute I saw your question: Why exactely do you have 4 Joomla installations? Please don't tell me for multilingual reasons, cause one Joomla installation can handle hundred languages... ANd what did you mean by "three URL redirects"? What kind of redirects, where do you use 'em and why? – Mikan Feb 4 '16 at 15:30
0

Depending on your hosting setup you may need to enable RewriteBase in the .htaccess file of the sub directory Joomla installs.

For example, uncomment and change this:

# RewriteBase /

to this:

RewriteBase /subdir1

References:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.