2

I'm running Joomla 3.4.8 and the Global Configuration page is showing without any layout or buttons. I have looked at the following:

forum.joomla.org/viewtopic.php?f=624&t=690980

but it doesn't seem to apply with 3.4.x.

I also removed the last two extensions that were added, JCE and Phocagallery but that did not correct the issue.

No other pages are being rendered incorrectly.

I would appreciate any suggestions. -ch

4
  • 3
    Try setting $error_reporting in your configuration.php to development, then try again. Report any errors back here
    – Lodder
    Feb 3 '16 at 14:37
  • changed $error_reporting to 'development'. When I try to go to the login screen, I get a 500 error. I can't login. Feb 4 '16 at 18:39
  • Have a look at this answer and this documentation article
    – Lodder
    Feb 4 '16 at 18:42
  • 1
    Hello, after set $error_reporting to development in the configuration file please place this line into your administrator index.php ini_set('display_errors', 1); Then post the error message here to see what we can do. Feb 11 '16 at 21:11
2

I had exactly the same problem in two sites: Global Configuration page is showing without any layout or buttons.

That worked for me:

A bclass.php file placed in: PATH_TO_JOOMLA_SITE/libraries/joomla/database/driver

After removing that file, the Global Configuration page went back to normal. Apparently this was a file from when the site is hacked.

1

Clearing the Joomla cache and your local browser cache can often fix this type of issue especially after updating from Joomla 2.5.8 to 3.x or after moving the website from one host to another.

0

Solution:

You need to re-install joomla version 3.4.8. Do this from your website folder on your web hosting server. NOT from Joomla back end where you install extension.

  1. Login to your hosting server admin panel.

  2. Locate "library" folder in your website folder and rename it to library-x. You can delete library-x later.

  3. Upload Joomla_3.4.8-Stable-Full_Package.zip to your website folder on your hosting server.

  4. Extract Joomla_3.4.8-Stable-Full_Package.zip to your website folder.

This will fix the problem. It did for mine.

0

In the solution suggestion on another website: there was a suggestion to remove bclass.php in libraries / joomla / database / driver. but I didn't have that file. In this case, I opened the driver folder in my old web site backup, I opened the current driver folder in front of it, an extra pgsql.php file appeared. When I disabled it, I checked the site and GENERAL CONFIGURATION worked. There was no problem on the website. :) (take a backup)

0

I rename PATH_TO_JOOMLA_SITE/libraries/joomla/database/driver pgsql.php to pgsql-removed.php and configs works for me!

New contributor
Daniel Alves is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • Thank you for contributing Daniel. Please take our tour.
    – mickmackusa
    yesterday

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.