4

As per the link here the version can be either 2.5 or 3.0. But my requirement is to have the version anything greater that 3.4 in 3.x series.

How this can be done? Should I go via scrip file? Or is there a simple setup in xml file itself?

6

You don't have to use only 2.5 or 3.0, you can also use 3.4 or any other Joomla version:

<extension type="component" version="3.4" method="upgrade">

The version attribute specifies the minimum Joomla! version needed for your extension, ie your extension will work with 3.4 and every version after that.

  • I understand that I can give any particular version. In that case when joomla 3.5 or any newer version released then I need to edit the manifest file... Is that something I can set greater than or equal to 3.4? – Malaiselvan Jan 29 '16 at 11:47
  • 1
    If you write "3.4" this means >= 3.4. It is the minimum Joomla! version required for your extension – fruppel Jan 29 '16 at 11:51
  • mmmmm I thought the extension will work only on that version.... OK good to know that it is the minimum version. – Malaiselvan Jan 29 '16 at 11:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.