2

When my user tries to edit an article in frontend, he gets "403 - you don't have permission to access(#some id of article)" and when he goes back in browser and tries again usually he can get access - sometimes he need to go back and try again few times. Now this is not happening all the time. I can even recreate this by adding user to different access group and after this trying to access some articles. Then I get 403 blabla, but after few tries I can access the articles editor.

What causes this? Is this because of some cache? Joomla cache is turned off, Apache cache is on. Maybe this is connected with my other stack question: https://stackoverflow.com/questions/35009053/random-redirect-301-only-in-firefox or could this be caused by rare packet drops?

Also I wanted to post this on official Joomla forum but my ip at work is banned on that forum. I really appreciate any help. I also posted this on stackoverflow: https://stackoverflow.com/questions/35031929/joomla-random-lack-of-permission-to-access

Sincerely, Thomas

  • 2
    You shouldn't post your question on multiple sites (ie cross posting). See also this answer about cross postings on stackexchange: meta.stackexchange.com/a/64069 – fruppel Jan 27 '16 at 15:08
  • Well, thank You for such info - won't happen again, but as I can see there is planty of people who can point what I did wrong with my question but almost none who can say something useful about actual question... :( – Thomas Kolasa Jan 27 '16 at 15:34
  • Try it with turned off Apache cache. You're already guessing that it's the cache and that would be my first guess too :-) – fruppel Jan 27 '16 at 19:06
  • Can you replicate the issue on a different environment, i.e locally? Have you installed any cache/seo 3rd party components or plugins recently? Check log files (Joomla and Server)? – jonboy Jan 27 '16 at 19:06
  • that will be first thing I'll do tomorrow @johnny_s :) checking if same thing is happening on my pc on xampp :) – Thomas Kolasa Jan 27 '16 at 20:04
3

I got a similar issue. Maybe my solution will help you.

I was not able to edit a second time my article and I was also receiving this message : You are not permitted to use that link to directly access that page (#article-id). The error was not appearing when my browser extension « Cache Killer » was activated and the same thing was going on with the mode debug. It could be a suitable solution for me, but not for my clients...

Take a look to your .htaccess file, if your site is not the primary one you should take a look to both of your .htaccess. Ex : home/mysite/mytestsite the .htacess of « mysite » will overrule the .htaccess of « mytestsite »

Search for : expiresdefault or ExpiresByType and comment it with a # and don't forget to clean your browser’s cache.

For my part it was :

ExpiresDefault "now plus 1 hour" 

that I comment :

# ExpiresDefault "now plus 1 hour"

Clean your browser’s cache and that it.

I hope that my solution will help.

  • Hello @jean I had it already done that way so this isn't it, but thank You for suggestion. :) – Thomas Kolasa Feb 3 '16 at 12:53
2

It well could be a cache problem, Joomla by default does not cache pages when logged in precisely because of such issues.

Mainly adding an answer to note that Apache can be set to cache only specific extensions, so it should be set to cache only extensions for images, scripts, and fonts. This will still occasionally cause issues and will not add performance that much since browsers will usually just check if the file has changed which with HTTP/1.1 is reasonably fast. But it will reduce server load which your administrator will like.

Also, is your Joomla set to give pages .html extension? Your server might be set to cache static web pages and recognize such by the .html extension. That might be the actual reason for the issue, in which case you can fix it by changing a Joomla setting, without bothering an administrator at all.

  • Hello @Ville, my Joomla isn't set to add .html extension. Do I understand correctly that Apache cache should be set in Apache config, yes? – Thomas Kolasa Feb 3 '16 at 12:56
1

Please test this Pull Request/Patch:

https://github.com/joomla/joomla-cms/pull/9035

  • Can't do this today. I'll check back after trying that patch. Also could this be guilty of random 301 redirects (noticed only in Firefox browser)? Thx @Phil – Thomas Kolasa Feb 3 '16 at 13:27
  • saddly it didn't help :( I can't wrap my mind around it :/ – Thomas Kolasa Feb 4 '16 at 7:33
  • Do you mean you could not work out how to apply the patch? or after applying the patch you still had issues? – Phil Taylor Feb 4 '16 at 13:39
  • after applying the patch I still have issues :( – Thomas Kolasa Feb 5 '16 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.