0

I have a category blog menu item and want to display a module in the full view of the article rather than teaser view. When I assign it to the main menu item it shows in teaser view as well, which I don't want. I have tried creating a hidden menu also but it is not working. I created a hidden menu and in modules > menu assignment I selected only hiddenblogmenu. But the issue is when I click the read more button in teaser view it redirects me to main menu item only. It is taking the blogmenu link rather than hiddenblogmenu link.

Following are the specification:

  • Category Blog Main menu : Blogmenu
  • Hidden menu : Hiddenblogmenu
  • Module to be displayed : Fullviewmodule

Kindly, suggest a solution to this

  • Let me make sure I understand. So you want the module to be shown only on the actual article page rather than on the category / blog layout? – Jesse Humphry Jan 19 '16 at 21:23
  • yes. there are 2 views of articles - teaser and full view. So, I want to display the module in full view (the page after read more button is clicked) and not in teaser view which is displays all articles in blog layout. – Liz. Jan 20 '16 at 5:18
2

It is important to note that there are three different views for articles as Joomla understands them. "Featured", "Category", and "Article", where the later is where you want your module viewed.

What you'll want to do is download the NoNumber Advanced Module Manager, which gives you significantly more options for setting module assignments, and you can find it right on the JED.

Once that is installed on Joomla, you can edit the modules in question and go to the "Assignments" tab. From here, select "Any" from the matching method.

Then, scroll down until you see "Joomla! Content" and select "Include" for the "Categories" option. Select all the categories that hold the articles you wish to apply the modules to, and then be sure that only the "Articles" page type checkbox is selected. Save and close this module.

For any additional modules you wish to be displayed in the same manner, go into this same editing page and select "Yes" for the "Same as other module" selection at the top. Then, from the drop down, select the first module you applied the parameters to. Then repeat the process for each module.

I hope this helped!

  • 1
    perfect solution! :) Thank you for a very clean and nice explanation. – Liz. Jan 20 '16 at 5:51
  • I'm glad I could help! – Jesse Humphry Jan 20 '16 at 7:53
0

You can try create a direct link to this article in some "hide menu" or some menu was unpublished.

Then you can assign your module to this item menu only.

With this tip you dont need any other plugin ir module.

I holpe this helps.

  • I don't need a single article link, I needed all the articles in category blog. And I tried the hidden menu way but it didn't work me. I have explained this in my question as well – Liz. Jan 20 '16 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.